Mark I quit working

My Mycroft Mark I quit working. It had been working fine and I did an update several weeks ago. But one day it would not connect to the wifi and when I tried to reboot, the eyes roll around but nothing ever happens.

I connected it to a keypad and HDMI monitor and restarted it. There was several pages of output, which I couldn’t capture as it went by too fast. I tried the old ctl S to stop the scrolling but it didn’t work.

It appears that it tries to start the CPU four times. The very last line reads:

— {end Kernel panic - not syncing: VFS: unable to mount root fs on unknown-block(179,2)

Looking at the last attempt there is this line:

CPU3: stopping
CPU3: 3 PID: 0 comm: swapper/3 not taimted 4.4.21 -v7+ #911

most of the other lines looked like going through the motions of booting.

Afterwards the machine is unresponsive to commands from the keyboard.

The machine does light up, and the knob works and you can scroll through test, reboot, illum, etc.

I am unsure how I might be able to print out or capture the output.

I have limited linux command line skills although I am a long time Ubuntu user.

Also, I am in Kansas City if that opens any channels for resolving this issue.

1 Like

Hey @Brickrat thanks for letting us know about this issue, and sorry that you’re experiencing it. The kernel panic you describe can sometimes happen with the MicroSD card inside the Mark 1 corrupts. The fix is to burn a new image to a new MicroSD card, open up the Mark 1 and replace the MicroSD card.

Let me check internally and see if we can set you up with some face to face service :slight_smile:

Kind regards,

@Brickrat Would be happy to help. Email me at and I would be happy to help.

Problem resolved.

Thanks to Nate for helping me get my Mark I running again.