Mark I doesn't function after running apt upgrade

So I sshed to the Mark I and did a sudo apt update & suso apt upgrade, rebooted and it stopped responding to the wake work and stopped playing any sound at all.

So I thought no problem, I’ll just do a factory reset through the menu. Doesn’t fix it. Still no response and no sound at all. Is there a way to actually do a successful factory reset? And why doing an upgrade borks everything?

1 Like

If you haven’t already, you might take a look at the Mycroft logs to see if any of the services are failing to start, or throwing errors. Information about where the logs live can be found on

I hit the same issue. I logged into it via HDMI/keyboard and found that wlan0 isn’t even seen as a link anymore. Likewise, it doesn’t hear or respond to anything, but I think services are running. It does try to speak to me when I use the button on it, but there’s no audio. This makes me think both the wlan and audio drivers are missing. This makes me think the upgrade of packages removed some driver-related ones. I looked at the apt cache on the system and didn’t see any packages from the original build to revert to (or maybe I missed them), so I think I’m just going to grab the image from here: (bottom of page), open up the case, and re-burn the image onto the SD.

There’s probably some apt pinning that needs to be done to avoid having people do this when it’s more finalised.

Ah, thanks for the reply. I figured I couldn’t be the only one that’s tried doing an upgrade. Do we know if the mycroft team are aware of this? Where would be the correct place to file a bug?

If you’ve got a reproducible bug (i.e. you can load the stock image onto an SD card, run the upgrade, and hit the error every time), the best place to report it is probably git hub (

This is pretty much the situation that I have. You might find my thread of interest.

Hi everyone,

If you have an issue after doing an apt upgrade of Mark 1, the really useful thing for us to be able to do diagnostics and troubleshooting is the /var/log/mycroft-update.log. As of version 8.22, the Mark 1 unit will check for updates around every hour, and do an apt-get update, check for updates, then do apt-get upgrade to pull them down.

We’ve had a couple of cases where doing this has removed some packages in the past, with unexpected results, generally due to the way apt-get upgrade handles dependencies.

So, TL;DR, your mycroft-update.log is useful for us to figure out what’s going on. GitHub Issues are lovely as well if you want to raise them against

Kind regards,