Mark 2 Will Not Power On

My Mark 2 was running fine and the screen went blank, no fan noise, nothing. I unplugged the device, waited several minutes, plugged it back in, and nothing happens. No fan, no noise, no light change on the display.

This is off of the original image shipped with the device.

Thanks for any help!

What have you tried so far? What were the results? What’s your comfort level with attempting to fix it?

Most likely another failed USB drive.

Try flashing an image on another USB and boot it.

1 Like

So far I have unplugged, waited varying lengths of time, re-plugged. I have tried Neon OS on my usb, their usb, the original mycroft usb, I have tried no usb. I am getting no indication that anything is happening, no lights, no sound, no fans, no reaction on the screen. Is there any combination of buttons or a switch to force a reboot?

Baconator, I’m comfortable doing almost anything with the device, I opened it briefly to look for anything loose and I did not see anything. Not looking forward to pulling the whole thing apart to check.

Would the usb-c deliver power to the whole device as opposed to the provided power cable/adapter? Thanks again!

You can try powering the pi itself…i have doubts that will work for the sj201 board and amp. Also send an email to support, while limited they may have other suggestions.

1 Like

It sounds like you’ve got it narrowed down to a hardware issue with your Mark II. :frowning: As @baconator said, I think it’s time to contact Mycroft’s support about it. Taking it apart is quite valid too, since they were built with that in mind. If you can identify a failed component I’m sure that would be helpful.

1 Like

I just encountered this exact same issue…any luck so far, @knox? I’ll be hitting up Mycroft Support too. :frowning:

Try to open up the device and use a 5 volt >2A USB-c power supply to power the Raspberry Pi4 inside strauight on the USB-c port it has.

Does it start / light up, it is most likely either the powerbrick or the SJ-201 hat.

Try to find a replacement power adapter with the same specs and see if that powerbrick is able to power up the device.

If it is, the power adapter is broken.
If it isn’t, the SJ-201 hardware is broken.


Had the same problem with my $300 clock. Tried everything. Received my Neon thumb drive OS. It booted immediately!

I messaged support.

Tried another power adapter without success, plugged in the raspberry pi at the usb-c port and got a red light.

With everything going on at Mycroft hopefully someone responds. Does anyone know if there are sj201 boards for sale anywhere?

I have a neon drive as well, no response. I at least had my $300 clock running HA.

Removing the SJ-201 board allows the OS to load while using the usb-c port for power.

So it appears it is the SJ-201 board, any ideas?

1 Like

Definitely contact support.

What’s the best way to reach support? I sent a message via the form on their website but haven’t heard back.

@gez-mycroft @michael-mycroft Could you guys help out here.

1 Like

Same for me, sent 2 different messages.

@gez-mycroft @michael-mycroft

Any help? It looks like the SJ-201 board failed.

Sadly, I’m pretty sure Gez is not around anymore.

Hey there, this really has to go through

Be aware that Mycroft has wound down normal operations, however Michael has committed to supporting the hardware as it was sold. So it might take longer than previously to get a response, but he will get back to you and if your SJ201 has died you should be eligible for a replacement.

As a general rule though - if you plug in power to the Mark II without any USB inserted, you should hear the fan spin up to max. If you get no fan, there’s definitely an issue with the power supply or the SJ201.


Discourse imposes a 20-character minimum, but words fail.