Mark 1 SSH commnad line interface not working

Hey guys, I’m a bit new to this but I tried to connect my mark 1 to the PC.

When I enter the command mycroft-cli-client , nothing happens. Am I doing this correctly? Basically, I just want to record and save audio through mark 1 microphone and access the file on my PC. Thanks

Are you running the command on the mark 1 or on your pc?

On PC, ubuntu terminal. I can connect to the device, but command cli interface doesnt work.

Hi sh77,

Can I check, from your ubuntu terminal have you SSH’d into the Mark 1? Your shell prompt should then read:

pi@mark_1:~ $

When you say nothing happens, do you mean just get a new blank shell prompt with nothing new output to the terminal? Eg:

pi@mark_1:~ $ mycroft-cli-client
pi@mark_1:~ $

Yeah, the second one

pi@mark_1:~ $ mycroft-cli-client
pi@mark_1:~ $

I’m pretty new to this, should’ve mentioned it clearly earlier, my bad.

Strange, I haven’t seen this happen before.

Let’s work backwards from the command and see what’s going wrong.

  1. For any command you can see where the executable is located using which:
which mycroft-cli-client

this should return


  1. Read the contents of that script to see what it’s doing:
cat /usr/bin/mycroft-cli-client

should return:

#!/usr/bin/env sh
/opt/venvs/mycroft-core/bin/mycroft-cli-client $@

  1. This shows the command is calling another executable so we’ll inspect that:
cat /opt/venvs/mycroft-core/bin/mycroft-cli-client

should return:

# EASY-INSTALL-ENTRY-SCRIPT: ‘mycroft-core==19.2.14’,‘console_scripts’,‘mycroft-cli-client’
requires = ‘mycroft-core==19.2.14’
import re
import sys
from pkg_resources import load_entry_point

if name == ‘main’:
sys.argv[0] = re.sub(r’(-script.pyw?|.exe)?$', ‘’, sys.argv[0])
load_entry_point(‘mycroft-core==19.2.14’, ‘console_scripts’, ‘mycroft-cli-client’)()

Are each of these as they should be?

when i enter cat /usr/local/bin/mycroft-cli-client

I got the large text below and the version specified for me is 0.8.17

Would the version be the issue in this case?

That’s a rather outdated version. 19.2 is the most current major release. Might need to update your mk1.

Yeah, I’ve set it to update, but I have to reset the device, every time I change the wifi so that’s gonna be cumbersome I guess.

And why you need to change the wifi? Having a Mark I, perhaps you should consider to re-image the SD with a newer image

It doesn’t connect to a new wifi without resetting, which is strange. Would re-image be the only solution to this?

try mycroft-wifi-setup wifi.reset - this will reset the wifi configuration and you can start the wifi setup process by connecting to wifi-ssid mycroft with password 12345678

or edit /etc/wpa_supplicant/wpa_supplicant.conf

Well, I’ve suggested to reimage because you have a very old Mycroft version and perhaps reimaging is quicker and easier, but you could try first what @Dominik says.

1 Like

Delete, I didn’t sleep last night

Just ignore again, still no sleep. Im sorry.

Zzzzzzzzzzzzzzzzzzzzzz zzzz zzzzz