Mark 1 not listening

I’ve been playing with my Mark 1 today after leaving it alone fr a while. All was well until suddenly it stopped listening altogether. I have tried a reset and multiple reboots. It responded well to my voice before, but now nothing.

I am SSHed into it and the skills log is ticking over slowly as I believe it should. The audio log hasn’t change for over an hour.

How can I check to see what it can hear?

I’m running a Mark 1 on 0.9.1

You can view the microphone level by starting up the command line client with mycroft-cli-client. At the bottom right you should see a visualization of the current audio intensity Mycroft hears. In addition, you can view the speech client logs in /var/log/mycroft-speech-client.log with the command, tail -f /var/log/mycroft-speech-client.log. There used to be a bug that caused the speech client to freeze when it reloaded the configuration, but it was fixed in 0.9.1. The last possible issue is that something in the advanced settings on got changed and the voice client crashes. If this is the case, try making sure the advanced settings are set the the following defaults:

Let me know what the logs / microphone level says :slight_smile:

1 Like


Many thanks for that. Very informative. I’ve never seen anything happen near the Mic Level on the cli. I assume that this means Mycroft is currently deaf. The levels were all at default except the Threshold which was 1e-40 as I’d been playing with it. Back at 1e-90 now.

Still nothing by Mic Level.

Again, thanks for the help.

Thanks for showing us the log, @CaptainFuzzyFace - there’s definitely no mycroft-speech or 'mycroft-audio` log entries there which suggests that your microphone is not being recognised.

Have you tried the following:

  • Do you have an alternate microphone that you could test with?
  • If you do arecord -d 5 test-mic.wav then aplay test-mic.wav does the microphone record and the headset play back?

Kind regards,


I’ve run those and yes it played back the sounds that it recorded. I take that as good news; that is to say that it isn’t a hardware fault and so we stand a fair chance of fixing it without using a hammer. :slight_smile:

I also ran a “sudo apt-get install -f mycroft-mark-1” and it reported that nothing needed doing.


1 Like

Hammers are definitely a last resort :slight_smile:

This is certainly strange. If you do lsusb do you see the microphone?
What does pavucontrol show?

Hammers have their place. :wink:

pi@mark_1:~ $ lsusb
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@mark_1:~ $ pavucontrol
-bash: pavucontrol: command not found

1 Like

OK I’m an idiot, of course the microphone isn’t connected via USB because it’s a Mark 1 device. pavucontrol can be used on Linux systems to select which audio inputs and outputs are used.

OK, I’m stumped on this one. @forslund is at a conference at the moment, but may have some more suggestions.

I’ll install pavucontrol and see how that goes.

Any more ideas, throw them my way.

For the record, I have “M AY K R AO F T” in my config and that has been working well for a while. Is there anything that I can change it to to ensure that it just doesn’t like my voice anymore? Or is that not relevant as there are no audio entries in the logs?

I’ll see if I can get an SD card adaptor and just flash it with 0.9.1 again. See if that fixes it…


Is there a period (.) at the end of “M AY K R AO F T”? A period signals the end of a word.

I’ve just added a period but it made no difference.

Found an SD card reader but now failing to find a screwdriver that can open the case…


Still can’t get the case open. Won’t try the hammer (yet).

Did manage to install pavucontrol and this is the result.

pi@mark_1:~ $ sudo pavucontrol
Unable to init server: Could not connect: Connection refused

That doesn’t look great to me, but maybe does point towards the problem?

I’ve been trying various things today and I notice that I get this on start-up.

15:45:18.547 - mycroft.configuration:__load:122 - DEBUG - Configuration ‘/home/pi/.mycroft/mycroft.conf’ not found

Should I have one? And shouldn’t the user be mycroft not pi?

More info

Search Results: exist ctrl+X to end 0-12 of 12

~~~~G - No dialog loaded, /opt/mycroft/skills/fallback-aiml/dialog/en-us does not exist
~~~~BUG - No vocab loaded, /opt/mycroft/skills/fallback-aiml/vocab/en-us does not exist
~~~~EBUG - No dialog loaded, /opt/mycroft/skills/skill-joke/dialog/en-us does not exist
~~~~ No dialog loaded, /opt/mycroft/skills/skill-mark1-demo/dialog/en-us does not exist
~~~~ - No vocab loaded, /opt/mycroft/skills/skill-mark1-demo/vocab/en-us does not exist
~~~~EBUG - No dialog loaded, /opt/mycroft/skills/skill-stop/dialog/en-us does not exist
~~~~ dialog loaded, /opt/mycroft/skills/fallback-duckduckgo/dialog/en-us does not exist
~~~~No vocab loaded, /opt/mycroft/skills/fallback-duckduckgo/vocab/en-us does not exist
~~~~alog loaded, /opt/mycroft/skills/skill-desktop-launcher/dialog/en-us does not exist
~~~~ - No dialog loaded, /opt/mycroft/skills/skill-spelling/dialog/en-us does not exist

I think that for these it is actually the dialog folders that are missing.

Hi CaptainFuzzyFace,

that does indeed look strange. The user should be mycroft (it should be looking for /home/mycroft/.mycroft/mycroft.conf)

It’s rather important as it points to the skill installer (msm) but should not affect the wakeword.

If you have changed the wakeword from the default

wakeword: hey mycroft
phonemes: HH EY . M AY K R AO F T

it might be worth a shot restoring those. @Wolfgange has done some fixing to allow better handle wakewords that should be included in the next release (coming any day now).


I got fed up with trying things and probably making them worse, so I have created a new SD card and reregistered it on However after successfully registering as a new device, it still doesn’t hear me. The SD card was burned on Ubuntu from the 0.91 image. Now I’m getting really peeved. I will not be defeated by AI!

Time to roll my sleeves up. Updates on this saga to follow.

@CaptainFuzzyFace - can you please give me your mycroft-skills.log output? I’ve seen a similar case today and want to see if the symptoms we saw with that case are present here as well.

Best, Kathy