Location in Florida wrong

When asking, “Where are you?”, Mycroft responds with, “I’m in Cocoa, Flevoland, Netherlands.” I have tried changing the location do a different state (New York) and Mycroft says the city, state, and country correctly. However, when I change to any city in Florida, Mycroft always responds with “Flevoland, Netherlands”. Is there a way to correct this?

Hey there @gmcglothin, thanks for reporting this, and sorry it’s been a niggle for you. This sounds like a bug we had a couple of months ago where home.mycroft.ai wasn’t picking up the right value from a select dropdown.

To confirm this I need to find out from you a couple of details:

  • Which Mycroft device are you working on?
  • Would you be comfortable sshing in to the device?

If so, what I need to find out is the information in your web_config_cache.json

Here’s the contents of the web_config_cache.json file:

{“date_format”: “MDY”, “tts”: {“espeak”: {“created_at”: 1516998489565, “updated_at”: 1518228216339}, “module”: “mimic”, “marytts”: {“created_at”: 1516998489560, “updated_at”: 1518228216668}, “mimic”: {“created_at”: 1516998489564, “voice”: “ap”, “updated_at”: 1518228215991}, “google”: {“created_at”: 1516998489562, “updated_at”: 1518228216177}, “fatts”: {“created_at”: 1516998489561, “updated_at”: 1518228216501}}, “opt_in”: true, “created_at”: 1516998489535, “updated_at”: 1518228212846, “listener”: {“energy_ratio”: 1.5, “created_at”: 1516998489568, “updated_at”: 1518228217055, “channels”: 1, “sample_rate”: 16000, “multiplier”: 1.0, “threshold”: 1e-40, “phonemes”: “HH EY . AO R F IY AH S”, “wake_word”: “hey orpheus”}, “time_format”: “half”, “skills”: {“directory”: “~/.mycroft/skills”, “created_at”: 1516998489566, “updated_at”: 1518228216848, “stop_threshold”: 2.0}, “stt”: {“google”: {“credential”: {“created_at”: 1516998489556, “updated_at”: 1518228215823}, “created_at”: 1516998489556, “updated_at”: 1518228215325}, “ibm”: {“credential”: {“created_at”: 1516998489548, “updated_at”: 1518228213216}, “created_at”: 1516998489548, “updated_at”: 1518228213062}, “mycroft”: {“credential”: {“created_at”: 1516998489551, “updated_at”: 1518228215158}, “created_at”: 1516998489551, “updated_at”: 1518228214647}, “module”: “mycroft”, “wit”: {“credential”: {“created_at”: 1516998489536, “updated_at”: 1518228214484}, “created_at”: 1516998489536, “updated_at”: 1518228214004}, “openstt”: {“credential”: {“created_at”: 1516998489544, “updated_at”: 1518228213842}, “created_at”: 1516998489544, “updated_at”: 1518228213373}}, “location”: {“coordinate”: {“latitude”: 28.386116, “created_at”: 1499108227829, “updated_at”: 1499108227829, “longitude”: -80.741998}, “city”: {“created_at”: 1499108227669, “state”: {“country”: {“created_at”: 1486844302087, “code”: “NL”, “name”: “Netherlands”, “updated_at”: 1486844302087}, “created_at”: 1486844302083, “code”: “FL”, “name”: “Flevoland”, “updated_at”: 1486844302083}, “code”: “Cocoa”, “name”: “Cocoa”, “updated_at”: 1499108227669}, “created_at”: 1499108227665, “updated_at”: 1499108227665, “timezone”: {“code”: “America/New_York”, “name”: “Eastern Standard Time”, “dst_offset”: 3600000, “created_at”: 1486068972406, “updated_at”: 1486068972406, “offset”: -18000000}}, “enclosure”: {“created_at”: 1516998489570, “rate”: 9600, “updated_at”: 1518228217238, “timeout”: 5.0, “port”: “/dev/ttyAMA0”}, “system_unit”: “imperial”}

Sorry, forgot to let you know what device. Working on a Raspberry Pi 3 with Picroft version 0.9.17.

That’s super helpful, thank you.

What I think has happened here is:

  • At some point in the past, you’ve hit the bug I mentioned earlier. My guess is that you’ve tried to select Cocoa Beach in Florida? The bug has caused the device to pick up Cocoa in the Netherlands. A second bug has caused the FL code to be populated in the ‘State’ field (ie Flevoland in the Netherlands), and now we can’t change it back.

  • In order to fix this, I think it will be a database change. Are you comfortable with me getting one of my colleagues to do a datafix for this? (we tightly control database access for privacy reasons).

Kind regards,

Actually, I selected both Cocoa and Cocoa Beach, Florida, US. Which showed up ok on the web configuration. I also selected Jupiter, Florida, US just to test and see if this was something local to Cocoa. But in all instances where Florida was the state, Mycroft kept saying Flevoland, Netherlands. Changed it to New York, New York, US and Mycroft got that one right. It’s not a big deal, but it seems like something that could be fixed with the database that the location is pulled from. I’m ok with whatever you have to do.

1 Like

Hi am having this same issue, for Nashville TN. My Mark I thinks he’s in Nashville Tamil Nadu India.


Thanks for flagging this @dmc - are you able to post the contents of your web_config_cache.json file

Hi Kathy,

Here’s the contents:

{“date_format”: “MDY”, “tts”: {“espeak”: {“created_at”: 1485749299420, “updated_at”: 1518981504337}, “module”: “mimic”, “marytts”: {“created_at”: 1485749299507, “updated_at”: 1518981505044}, “mimic”: {“created_at”: 1485749299447, “voice”: “ap”, “updated_at”: 1518981504690}, “google”: {“created_at”: 1485749299378, “updated_at”: 1518981504510}, “fatts”: {“created_at”: 1485749299476, “updated_at”: 1518981504875}}, “opt_in”: true, “created_at”: 1485749298977, “updated_at”: 1518981500879, “listener”: {“energy_ratio”: 1.5, “created_at”: 1485749299565, “updated_at”: 1518981505658, “channels”: 1, “sample_rate”: 16000, “multiplier”: 1.0, “threshold”: 1e-90, “phonemes”: “HH EY . M AY K R AO F T”, “wake_word”: “hey mycroft”}, “time_format”: “half”, “skills”: {“directory”: “~/.mycroft/skills”, “created_at”: 1485749299538, “updated_at”: 1518981505250, “stop_threshold”: 2.0}, “stt”: {“google”: {“credential”: {“created_at”: 1485749298995, “updated_at”: 1518981501621}, “created_at”: 1485749298995, “updated_at”: 1518981501120}, “ibm”: {“credential”: {“created_at”: 1485749299144, “updated_at”: 1518981502682}, “created_at”: 1485749299144, “updated_at”: 1518981502504}, “mycroft”: {“credential”: {“created_at”: 1485749299288, “updated_at”: 1518981504148}, “created_at”: 1485749299287, “updated_at”: 1518981503585}, “module”: “mycroft”, “wit”: {“credential”: {“created_at”: 1485749299065, “updated_at”: 1518981502331}, “created_at”: 1485749299065, “updated_at”: 1518981501794}, “openstt”: {“credential”: {“created_at”: 1485749299217, “updated_at”: 1518981503400}, “created_at”: 1485749299217, “updated_at”: 1518981502853}}, “location”: {“coordinate”: {“latitude”: 36.17815, “created_at”: 1520035259925, “updated_at”: 1520035259925, “longitude”: -86.739123}, “city”: {“created_at”: 1520035259889, “state”: {“country”: {“created_at”: 1486136631094, “code”: “IN”, “name”: “India”, “updated_at”: 1486136631094}, “created_at”: 1487169639787, “code”: “TN”, “name”: “Tamil Nadu”, “updated_at”: 1487169639787}, “code”: “Nashville”, “name”: “Nashville”, “updated_at”: 1520035259889}, “created_at”: 1520035259888, “updated_at”: 1520035259888, “timezone”: {“code”: “America/Chicago”, “name”: “Central Standard Time”, “dst_offset”: 3600000, “created_at”: 1486060240386, “updated_at”: 1486060240386, “offset”: -21600000}}, “enclosure”: {“created_at”: 1485749299591, “rate”: 9600, “updated_at”: 1518981506021, “timeout”: 5.0, “port”: “/dev/ttyAMA0”}, “system_unit”: “imperial”}

Thanks for flagging this @dmc.
I’m going to ping my colleague @matheus-mycroft, who I think has a datafix / workaround for this issue.
Matheus - let me know if there’s anything you need tme to do here,

Kind regards,

Where is the web_config_cache.json located on the pi?



I tried sudo nano /opt/mycroft/skills/web_config_cache.json, but the file is blank.

Is this correct?

can you paste an ls -las of that directory - ie /opt/mycroft/skills so I can have a look?

Best, Kathy

pi@picroft:/opt/mycroft/skills $ ls -las
total 8
4 drwxrwxrwx 2 mycroft mycroft 4096 Jan 13 2017 .
4 drwxr-xr-x 4 mycroft mycroft 4096 Jan 26 2017

Thanks, that shows the file doesn’t exist.

What I think we might need to do here is re-pair the Device. Are you able to remove the Device from home.mycroft.ai and then Pair again?

Sorry for the hassle.

I’ll give that a try. I saw your response to my other post and I’m downloading the newer image.

I’ll let you know how that works.

Thanks for the help :slight_smile:

You’re very welcome, we’re here to help! Please do let us know how you go.