June20th - curious did you make any audio updates - as the mic input broke

was wondering if you made any updates today to mycroft software as june 20th… everything was working fine yesterday today their was no mic input to mycroft
. the mic worked on the OS system itself but no input going to mycroft.

took me a while to get it work again. perhaps if someone else encounters the same issue this seams to to have fixed it for me…

first disable mycroft from starting at boot. ( reboot)
2nd run Unittest
3rd run audiotest ( if i did not do the above first mycroft audiotest would freeze while doing the audio test)

after doing this the mic input worked again and mycroft voice recognition worked.

it seamed that the mycroft alsa plugin would not load prior to doing this

We have multiple commits being pushed to the dev branch most days, but nothing should have changed on stable from Mycroft’s end. Perhaps some system updates?

When the alsa plugin wasn’t loading were you getting any particular error messages?

no system update was done… it came out of the blue… I notice it would do it from time to time the mic stop working maybe every few weeks. but usually after a power disturbance ie flickering lights. i just figure the pi stalled. but a simple reboot would correct that… today nothing would correct the issue… until I dug deeper and noticed the alsa plugin would not load… even though the mic physically worked. mycroft debug displayed no error that i noticed . and mycroft worked fine as my weather alert software could send notification to it an it would speak-- just no mic input…

the audio & enclosure log had this as an error several times around the time I was trying to get it to work ( now it does not have that error) but I do not know if it is related or not

Traceback (most recent call last):
File “/home/ai/mycroft-core/mycroft/messagebus/client/ws.py”, line 77, in on_error
self.emitter.emit(‘error’, error)
File “/home/ai/mycroft-core/.venv/lib/python3.5/site-packages/pyee/init.py”, line 178, in emit
raise args[0]
File “/home/ai/mycroft-core/.venv/lib/python3.5/site-packages/websocket/_app.py”, line 305, in run_forever
dispatcher.read(self.sock.sock, read, check)
File “/home/ai/mycroft-core/.venv/lib/python3.5/site-packages/websocket/_app.py”, line 53, in read
if not read_callback():
File “/home/ai/mycroft-core/.venv/lib/python3.5/site-packages/websocket/_app.py”, line 271, in read
op_code, frame = self.sock.recv_data_frame(True)
File “/home/ai/mycroft-core/.venv/lib/python3.5/site-packages/websocket/_core.py”, line 340, in recv_data_frame
frame = self.recv_frame()
File “/home/ai/mycroft-core/.venv/lib/python3.5/site-packages/websocket/_core.py”, line 374, in recv_frame
return self.frame_buffer.recv_frame()
File “/home/ai/mycroft-core/.venv/lib/python3.5/site-packages/websocket/_abnf.py”, line 361, in recv_frame
File “/home/ai/mycroft-core/.venv/lib/python3.5/site-packages/websocket/_abnf.py”, line 309, in recv_header
header = self.recv_strict(2)
File "/home/ai/mycroft-core/.venv/lib/python3.5/site-packages/websocket/abnf.py", line 396, in recv_strict
= self.recv(min(16384, shortage))
File “/home/ai/mycroft-core/.venv/lib/python3.5/site-packages/websocket/_core.py”, line 449, in _recv
return recv(self.sock, bufsize)
File “/home/ai/mycroft-core/.venv/lib/python3.5/site-packages/websocket/_socket.py”, line 94, in recv
“Connection is already closed.”)
websocket._exceptions.WebSocketConnectionClosedException: Connection is already closed.

but the above seam to correct the issue currently – i will keep a closer eye on it and see if it happen again