Is the Mycroft Server gone for good, or just down?

I am continuing to use my “old” PiCroft (Mycroft on a Raspberry Pi), largely because the Mark II with Neon has just not been that reliable (right now it does not even answer to the wake word). But today the PiCroft says it can’t connect to Mycroft servers. I know they will go eventually, but is that time now, or is this just a temporary problem? Thanks…

Hi Burns, unfortunately, the time we all knew was coming has arrived. All servers associated with are down.

1 Like

Well damn! Now I have to spend more time figuring out how to make my Mark II work. Right now it does not respond to the wake word at all (you made suggestions about STT and TTS earlier but I have not gotten to that. Suggestions? Sorry, I just can’t find stuff in that Element conversation after a day or 2.

Forgive me for not remembering, did you make it onto SSD yet? I think that’s step one if not.

And yes, it’s going to be really helpful to have more conversations on here now. :slight_smile:

Yes, unfortunately all servers associated with Mycroft AI are down now.

For anyone else looking to boot up a Neon AI drive that’s been unused, we upgraded to V2.0 in August 2023. If your drive is older than that you will need a fresh image to make it run properly.

Here is a link to our page explaining options for that upgrade: Upgrade Guide - Neon OS V2.0 for the Mark II | Neon AI

1 Like

No problem, Clary. I bought the same SSD that you are selling, but not through you (you were out at the time or something). I believe I already upgraded to V2 but a week or so ago asked Neon to check for updates and then to do it (don’t remember the latest version) and after that no response at all to the wake word. It boots, I can login via SSH, I can use the screen pulldown. It’s just deaf. (I did try the mike-off switch…that’s not it).

It seems that the Mark 2 you have is dropping internet connectivity occasionally, which then leads it to fall back to on-device options that bog down the hardware badly enough it seems like it’s not running. Please give this a try first, and see if it helps:

    - ovos-tts-plugin-server==0.0.2a12
    - ovos-stt-plugin-server==0.0.4a7
  module: ovos-tts-plugin-server
    fallback_module: ""
  module: ovos-stt-plugin-server
  fallback_module: ""

That will set up some remote public STT and TTS. STT will default to FasterWhisper (great quality, good speed) and TTS will use Piper. Explicitly setting your fallback_module for each to a null value means if you have internet loss, STT and TTS won’t work, but your device also won’t get bogged down.

I also blacklist any skills I know I’m not going to use. It isn’t noticeable right away, but Padatious scales poorly with more intents, so bringing that number down improves performance. That list will vary per person, of course, but here’s what I default to off (sorry Clary!)

  - skill-audio-record.neongeckocom
  - skill-communication.neongeckocom
  - skill-fallback-llm.neongeckocom
  - skill-free-music-archive.neongeckocom
  - skill-ip-address.neongeckocom
  - skill-launcher.neongeckocom
  - skill-local-music.neongeckocom
  - skill-speed-test.neongeckocom
  - skill-spelling.neongeckocom
  - skill-stock.neongeckocom
  - skill-translation.neongeckocom
  - skill-somafm.openvoiceos
  - skill-ovos-setup.openvoiceos
  - skill-messaging.neongeckocom
  - skill-custom_conversation.neongeckocom
  - skill-instructions.neongeckocom
  - skill-audio_record.neongeckocom
  - mycroft-wiki.mycroftai
  - mycroft-joke.mycroftai
  - skill-caffeinewiz.neongeckocom

The wakeword engines are pretty lightweight and shouldn’t give you any grief leaving the defaults in place.

Please try this out and let’s see if that makes the Mark 2 usable again. At that point you should be able to troubleshoot what else is not working properly and continue to improve performance. I use versions of FasterWhisper and Coqui running on my home network, but not on the Mark 2, to keep things completely local and private. Bonus - if I lose internet, my assistant still works. :slight_smile: I think I shared the Piper script with you but unfortunately have not yet completed one for FasterWhisper. Local STT off-device should give you the best performance boost. I’ll share it as soon as I have it written.

1 Like

Nope. No change. It does not even tell me it has booted by now. But in admin.log, I see this:

2024-02-16 09:55:46.210 - admin - ovos_PHAL.admin:load_plugins:63 - INFO - PHAL Admin plugin loaded: neon-phal-plugin-device-updater
2024-02-16 09:55:46.339 - admin - neon_phal_plugin_linear_led.neopixel_led:__init__:47 - INFO - Initializing NeoPixel LEDs
2024-02-16 09:55:46.829 - admin - ovos_PHAL.admin:load_plugins:63 - INFO - PHAL Admin plugin loaded: neon-phal-plugin-linear-led-neopixel
2024-02-16 09:55:46.836 - admin - ovos_PHAL.admin:load_plugins:63 - INFO - PHAL Admin plugin loaded: neon-phal-plugin-reset
2024-02-16 09:55:46.841 - admin - neon_enclosure.admin.service:start:50 - INFO - Started Admin PHAL
2024-02-16 09:55:51.795 - admin - neon_phal_plugin_linear_led:is_muted:206 - WARNING - No mic status response, use last known value
2024-02-16 09:55:51.859 - admin - neon_phal_plugin_linear_led:is_muted:206 - WARNING - No mic status response, use last known value
2024-02-16 09:59:39.415 - admin - neon_phal_plugin_linear_led:is_muted:206 - WARNING - No mic status response, use last known value
2024-02-16 09:59:42.419 - admin - neon_phal_plugin_linear_led:internet_disconnected:223 - WARNING - No network status responses, use last known va

Sure wish it would stay in the right timezone!

Maybe I should just start from scratch.

That is definitely unusual. A fresh drive and image might be a good idea.

Ok, I updated to the latest in Neon AI OS for the Mark II | Neon AI

Wake word seems ok now, but back to the “it takes several minutes to respond” bit, and nothing showing on the screen while I wait. Top show “” taking up abut 60% of the CPU, with ovos-shell at 54. A few percent each for a number of others. I’ll try the config stuff above now. I assume this is for neon.yaml, I’ll work on this before I even try to put my hubitat skill in.

I hope you will forgive me for being totally irritated, but:

  1. The only speech device that ever worked reliably (Picroft) was turned off
  2. Mark II with Neon never worked well, and is just getting worse even without my own skill.
  3. The fixes suggested in yaml files are so bloody fussy, and there is no clue what is wrong with them. The software just deletes the updates and replaces them with the original. I admit to not be conversant with yaml, but that makes it all the harder to debug.

I know everyone has tried to help, and I appreciate it, but nothing seems to work. I’m frustrated.

1 Like

As a last resort, I tried connecting the MkII with CAT5. That seems to improve the response time considerably, although lots of things that I say that it apparently does not understand like “what is my timezone?” just get ignored. The log says “nothing transcribed”. In fact with that last one, it tried a fallback STT and got nothing.

Note that I am about 10 feet from the wifi hot spot, and nothing else has had any problem in the house, including the hubitat itself!

Hmm, I think this comment may point us toward an answer! Which neon.yaml file are you editing? The one at ~/.config/neon/neon.yaml or another one? The one at the path I mentioned should remain untouched no matter what, while the others will be overwritten on upgrades because they aren’t meant to be changed by users.

1 Like

Apologies for the frustrating experience. I felt much the same way when first setting up my Mark 2, especially when the Picroft on the shelf was still working perfectly fine. I think the changes in the YAML I suggested will make a big impact based on the feedback you’ve provided in this thread. It sounds like a mix of fussy/inconsistent STT, the device falling back to plugins it can’t really handle, and some network oddities.

By the way, there is an OVOS answer to the Picroft: GitHub - OpenVoiceOS/raspOVOS: Run ovos ontop of RaspberryPiOS

It’ll be a little slow on a Pi 3, but runs great on a Pi 4. @builderjer can give you more information on that.

1 Like

Sorry, I don’t get it. Which one is ok to change? In fact where ARE the other ones? I did change the one in ~/.config/neon/neon.yaml.

Okay, then the mystery deepens, because nothing in Neon should be changing that file…

If you would like to try something different, there is a OVOS image available for testing on the mark2.
Index of /raspbian/newest/

This is a bleeding edge image, so there may be bugs, but i try and address them quickly

1 Like

Thanks. I think I will stick with Neon for the moment, although I’m still mystified why hardwired works so much better than wifi.

@mikejgray, it seems to be that it was common in the past that the system would delete malformed yaml files. What should happen if the one in .config/neon is bad?

I haven’t experienced that myself, but I usually run neon.yaml through a YAML checker before I restart the services. If you want to do it directly on device, sudo apt install yq and cat ~/.config/neon/neon.yaml | yq will do it. I don’t recall the way to persist additional package updates past upgrades though.