Intent_failure on most core skills

Mark1 successfully recognizes and executes IP address and hello world skills. However, most of the rest of the skills I’ve tested result in intent failure (little excerpt from the CLI log below). I’ve tried the everything on the list. Interestingly, I was able to install daily mediation (but not easter eggs) skill.

The utterance recognized looks correct, just seems to be missing the intent. And indeed typing it in from the CLI has the same result (“sorry, didn’t catch that…”)

Total power cycle does not seem to help the problem. This has been the case since unboxing; i.e., this unit has not previously successfully executed skills other than hello world, ip address, and install skill. I would be grateful for some guidance on fixing Mycroft.

20:13:31.396 - mycroft.client.speech.mic:listen:499 - DEBUG - Waiting for wake word…
20:13:31.808 - mycroft.client.speech.listener:transcribe:144 - DEBUG - STT: what time is it
20:13:31.811 - mycroft.client.speech.main:handle_utterance:55 - INFO - Utterance: [u’what time is it’]
20:13:31.819 - SKILLS - DEBUG - {“type”: “recognizer_loop:utterance”, “data”: {“lang”: “en-US”, “session”: “827e91a1-fcc0-4aa1-974b-b869e90d2655”, “utterances”: [“what time is it”]}, “context”: null}
20:13:31.851 - SKILLS - DEBUG - {“type”: “intent_failure”, “data”: {“lang”: “en-US”, “utterance”: “what time is it”}, “context”: null}

Hey there @jrwarwick, sorry to hear you’re having these issues with your Mark 1.
I’m going to get you to try an update manually;

sudo apt-get update && sudo apt-get upgrade mycroft-mark-1

This should pull down the latest version of the Mark 1 software and also update the core skills. The Core Skills are tose that are mentioned in Get Started - ie the ones that come pre-installed.

Thanks for the fast reply, @KathyReid. The update got underway but hit a snag partway through. From the console:

Hit jessie/non-free armhf Packages
Hit jessie/rpi armhf Packages
Ign jessie/main Translation-en_GB
Ign jessie/main Translation-en
Ign jessie/ui Translation-en_GB
Ign jessie/ui Translation-en
Ign jessie/contrib Translation-en_GB
Ign jessie/contrib Translation-en
Ign jessie/main Translation-en_GB
Ign jessie/main Translation-en
Ign jessie/non-free Translation-en_GB
Ign jessie/non-free Translation-en
Ign jessie/rpi Translation-en_GB
Ign jessie/rpi Translation-en
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
pi@mark_1:~ $

I went ahead and issued the sudo dpkg --configure -a . I capture full output, but in summary, most of it looked nominal except for this part:

A pi user was detected, assuming this is Rasbpian on a Raspberry Pi
Creating soft link from /opt/mycroft/skills to /home/pi
ln: failed to create symbolic link ‘/home/pi/skills’: File exists
Checking for previous enclosure version file
A previous Mark 1 enclosure version file is present
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0 66633    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0

gzip: stdin: decompression OK, trailing garbage ignored
tar: Child returned status 2
tar: Error is not recoverable: exiting now
Initializing init script for mycroft-enclosure-client
Starting Mycroft service mycroft-enclosure-client

I can’t tell what it had trouble un-tar-ing, but the situation remains the same: IP and hello world work, time and alarms (and so on) do not.

Success! I added an apt-get clean to the front your recommended manual upgrade, and that processed cleanly
sudo apt-get clean && sudo apt-get update && sudo apt-get upgrade mycroft-mark-1

After a reboot, Mycroft is now successfully determining intent and utilizing skills. Issue resolved. Thanks for your help, Kathy.

1 Like

Our pleasure, @jrwarwick! Thanks for confirming you’re up and running!
Best, Kathy