Installation Problem

OS: Kubuntu 16.04
KDE Plasma 5.8.8
Qt 5.6.1
Kernel: 4.4.0-116-generic
Type: 64-bit

On trying to install, script included tries to remove several programs I use, like SimpleScreenRecorder and Blender. From what I gather, the guilty party is one of the dependencies of one of the programs installed in the process.

Is this normal, or do I need to stop using those programs in order to test Mycroft?


Hey @Manticore010, this is very unusual - I haven’t seen this behavior before. Do you know which dependency it is that’s doing the removal?

Thank you for your prompt reply, Kathy. This is what I get when I try to install:

$ bash
Installing packages…
[sudo] password for manticore010:
Reading package lists… Done
Building dependency tree
Reading state information… Done
autoconf is already the newest version (2.69-9).
automake is already the newest version (1:1.15-4ubuntu1).
build-essential is already the newest version (12.1ubuntu2).
libtool is already the newest version (2.4.6-0.1).
screen is already the newest version (4.3.1-2build1).
curl is already the newest version (7.47.0-1ubuntu2.6).
git is already the newest version (1:2.7.4-0ubuntu1.3).
python is already the newest version (2.7.12-1~16.04).
The following packages were automatically installed and are no longer required:
blender-data gstreamer1.0-plugins-base:i386 libasn1-8-heimdal:i386 libasound2:i386 libasyncns0:i386 libavahi-client3:i386
libavahi-common-data:i386 libavahi-common3:i386 libboost-locale1.58.0 libboost-regex1.58.0 libcapi20-3 libcapi20-3:i386
libcdparanoia0:i386 libcups2:i386 libdbus-1-3:i386 libexif12:i386 libflac8:i386 libfontconfig1:i386 libfreetype6:i386
libgd3:i386 libglib2.0-0:i386 libgmp10:i386 libgnutls30:i386 libgphoto2-6:i386 libgphoto2-port12:i386 libgsm1:i386
libgssapi-krb5-2:i386 libgssapi3-heimdal:i386 libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386
libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386 libhogweed4:i386 libhx509-5-heimdal:i386
libicu55:i386 libidn11:i386 libieee1284-3:i386 libjbig0:i386 libjemalloc1 libjpeg-turbo8:i386 libjpeg8:i386
libjson-c2:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-26-heimdal:i386 libkrb5-3:i386 libkrb5support0:i386
liblcms2-2:i386 libldap-2.4-2:i386 libltdl7:i386 libmpg123-0:i386 libnettle6:i386 libodbc1:i386 libogg0:i386
libopenal1:i386 libopencolorio1v5 libopenimageio1.6 libopus0:i386 liborc-0.4-0:i386 libosmesa6:i386 libp11-kit0:i386
libpcap0.8:i386 libpng12-0:i386 libpulse0:i386 libroken18-heimdal:i386 libsamplerate0:i386 libsane:i386 libsasl2-2:i386
libsasl2-modules:i386 libsasl2-modules-db:i386 libsndfile1:i386 libspeexdsp1:i386 libspnav0 libsqlite3-0:i386
libssl1.0.0:i386 libtasn1-6:i386 libtheora0:i386 libtiff5:i386 libusb-1.0-0:i386 libv4l-0:i386 libv4lconvert0:i386
libvisual-0.4-0:i386 libvorbis0a:i386 libvorbisenc2:i386 libvpx3:i386 libwind0-heimdal:i386 libwrap0:i386
libxcomposite1:i386 libxcursor1:i386 libxi6:i386 libxinerama1:i386 libxml2:i386 libxpm4:i386 libxrandr2:i386
libxrender1:i386 libxslt1.1:i386 libyaml-cpp0.3v5 wine-stable-amd64
Use ‘sudo apt autoremove’ to remove them.
The following additional packages will be installed:
icu-devtools libasound2-dev libbison-dev libexpat1-dev libfann2 libjack-dev libjack0 libjpeg-turbo8-dev libjpeg8-dev
libjs-sphinxdoc libonig2 libpcre3-dev libpcre32-3 libpcrecpp0v5 libportaudiocpp0 libpython-dev libpython2.7-dev
libssl-doc python-dateutil python-gi-dev python-gobject-2-dev python-magic python-pbr python-pip-whl python-stevedore
python2.7-dev python3-virtualenv swig3.0 uuid-dev virtualenv virtualenv-clone zlib1g-dev
Suggested packages:
bison-doc libasound2-doc libfann-doc libglib2.0-doc icu-doc jackd1 jackd nas oss4-base portaudio19-doc
python-setuptools-doc swig-doc swig-examples swig3.0-examples swig3.0-doc
The following packages will be REMOVED:
** blender libasound2-plugins:i386 libjack-jackd2-0 libjack-jackd2-0:i386 simplescreenrecorder star-wars-battlefront-2:i386**
** wine-stable wine-stable-i386:i386 winehq-stable:i386**
The following NEW packages will be installed:
bison flac icu-devtools jq libasound2-dev libbison-dev libexpat1-dev libfann-dev libfann2 libffi-dev libglib2.0-dev
libicu-dev libjack-dev libjack0 libjpeg-dev libjpeg-turbo8-dev libjpeg8-dev libjs-sphinxdoc libonig2 libpcre3-dev
libpcre32-3 libpcrecpp0v5 libportaudiocpp0 libpython-dev libpython2.7-dev libssl-dev libssl-doc mpg123 pkg-config
portaudio19-dev python-dateutil python-dev python-gi-dev python-gobject-2-dev python-gobject-dev python-magic python-pbr
python-pip-whl python-setuptools python-stevedore python-virtualenv python2.7-dev python3-virtualenv s3cmd swig swig3.0
uuid-dev virtualenv virtualenv-clone virtualenvwrapper zlib1g-dev
0 upgraded, 51 newly installed, 9 to remove and 0 not upgraded.
Need to get 46.7 MB of archives.
After this operation, 150 MB disk space will be freed.

My system is up to date, clean, and running as I want it. But, as you see, it will uninstall Blender, Simple Screen Recorder, Star Wars Battlefront 2, Wine, and a couple of sound libraries Open Shot uses. All those are vital for me, so I cannot install Mycroft without first being sure I’ll be able to reinstall all those programs after.

I’ve gone through some of the dependencies to see which one is messing things up, but there are 51 new packages it plans to install, so checking to find the one is going to take me a long time.

Thank you,

~$ manticore.

1 Like

Something in the package list conflicts, and it’s being told to install the new stuff, hence the need to remove things (if you were to continue). If you are tied to those packages, then you’d be better off installing in a VM or a separate system.

That’s super helpful information, thanks @Manticore010.
mycroft-core should NOT cause the removal of packages like wine and blender (and I’m a huge OpenShot user too, totally understand why you need to keep these packages).

I also wonder whether it’s worth doing a sudo apt-get update on your system before trying to run / just to make sure you’re installing from a known good state, just in case there’s an existing dpkg error?

I’m going to flag @forslund here to see if we’ve seen anything like this in the past .

I am also an openshot user and have not seen this issue before :confused:

The best advise I can give is that you do a “binary search” for the package, try installing half of the packages and see if the problem is there. If it is, try half of those packages otherwise try the other half and continue in that fashion.

Sorry for not being more helpful :frowning:

I’m scrupulous about keeping my system updated and all conflicts resolved. So at the start of each session I run:

$ sudo apt-get update && sudo apt-get upgrade && sudo apt-get autoremove

just to make sure. It’s taken me a while, but my Kubuntu is exactly as I want it, even Discover works well.

I’m interested in voice control due to limited eyesight. That makes it easier for me to control the computers, and of course I don’t plan to stop using Linux after all these years.

However, for now, I think I’m refraining from using Mycroft for a while. I’m afraid of breaking the perfect balance I have now that allows me to record video, edit it, and post-edit it using Adobe tools (on Wine).

I promise I’ll be back.

~$ manticore.

Thanks for letting us know @Manticore010, we’re looking forward to seeing you when you come back. Let us know if we can assist you further at all.

Kind regards, Kathy

Was this issue ever resolved? I’ve slammed into it here using Ubuntu 21.10, using the git clone source

./ contains the following:
if dpkg -V libjack-jackd2-0 > /dev/null 2>&1 && [[ -z ${CI} ]] ; then

it prints:We have detected that your computer has the libjack-jackd2-0 package installed.

and yes, now it wants to remove critical packages in a ubuntu-studio installation, everything involved with jackd2, while adding jackd1 and replacing libjack0 and libjack-dev

update - doing the debian packages in manually, it appears the culprit is portaudio19-dev that triggers reverting back to jackd1, jackd1-firewire, libasound2-dev, libjack-dev, libjack0, and libportaudiocpp0

update #2 - I installed portaudio19 from sources and the dev_setup seemed to like it, but so far I have not been able to get mycroft to respond to voice, so the adventure continues.

Actually I found the solution for this.

Jack2 must meet all the requirements, but Portable Audio only checks for Jack0.

To fix it, just install the development files for Jack2 :

$ sudo apt-get install libkjack-jackd2-dev

Then install the Portable Audio dev files:

$ sudo apt-get portaudio19-dev

And Mycroft should work fine, without uninstalling anything on a base LTS Ubuntu installation (I’m using 20.04 now but this also worked in 16.04).

~$ manticore.

1 Like