ImportError: No module named 'numpy'

I am working on a skill and when I run it numpy is not found.
When I run the numpy from python it works fine.

Does someone know how to solve it?

Thank You,
Alon Yom Tov

Mycroft-core runs with its on Python-venv. Try mycroft-pip install numpy on the console.


Thank you it worked.
Now I have a problem with importing my own file.
With one file everything is fine when I import it but with this one it doesn’t work?

Do you have an idea why?

Thank You,
Alon Yom Tov

I am sorry but I don’t understand what exactly is meant by “importing my own file”. Can you be more specific and share a code example?

In my skill I have a file named with getUserData() function in it.
From my main file I try to import it like this: from sqlGui import getUserData.
It returns an error like the file isn’t there.
When I tried to import a file from a different directory it worked.
Do you have an idea why?
Thank You

When the file name is then your import command should be from sql_gui import getUserData

That is what I did. Sorry from the typing error.
I did as you said, it still doesn’t work