ImportError: cannot import name 'AdaptService'

I can’t run “./ debug”, when i do this i got this fail code:

Traceback (most recent call last):
File “/usr/lib/python3.6/”, line 183, in _run_module_as_main
mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
File “/usr/lib/python3.6/”, line 109, in _get_module_details
File “/home/jesus/Downloads/Mycroft/mycroft-core/mycroft/”, line 22, in
from mycroft.skills.intent_service import AdaptIntent
File “/home/jesus/Downloads/Mycroft/mycroft-core/mycroft/skills/”, line 24, in
from .intent_services import (
ImportError: cannot import name ‘AdaptService’

I’m using Kubuntu 18.04, Python 3.6.9 and i run “bash” succesfully.
Can someone help me please?

Hi Jesus,

That’s a strange one. Can you check that the file:



from .adapt_service import AdaptService, AdaptIntent
from .base import IntentMatch
from .fallback_service import FallbackService
from .padatious_service import PadatiousService

I’m assuming you followed the basic git clone method to get setup?

1 Like

I Will check, yes, i followed the git clone method, but when i tried to run “./ debut” i round this error code.
Thanks You, when i check i’m going to tell You.