[HOWTO] Begin your Open Voice OS journey with the ovos-installer 💖 😍

Kudos to the author. Up and running on the first swing. Well done.


Glad to read!

Worked up to the depmod step: dpaste: AX9959444

Probaboy because I’ve updated to the latest RPi OS, and it’s a new kernel.

Linux megamax 6.6.31+rpt-rpi-v8 #1 SMP PREEMPT Debian 1:6.6.31-1+rpt1 (2024-05-29) aarch64 GNU/Linux

Indeed, only kernel 6.6.22 is currently supported by the installer.

I got an issue open to improve this Handle kernel newer than 6.6.22 during installation · Issue #99 · OpenVoiceOS/ovos-installer · GitHub

looking at the code, it seems that updating _ovos_hardware_mark2_kernel_target in the ansible tree will get me over the hump as a temp fix. Will that be sufficient?

Maybe not - as I look more closely. But others are going to have the same problem, as the version of the OS on line has been updated, as you probably know (that’s where I got it)

Please try this PR:

Just tested with a fresh Raspberry Pi OS Bookwork 64-bit Lite install (kernel 6.6.31) and it worked without any issue.

Bingo!! Worked like a charm!


1 Like

Doesn’t respond to Hey Mycroft, but I’ve gotta go. I’ll try it later.

Reboot might be required since you already ran the installer.

My first experience with OVOS, so I don’t know what to expect. I don’t think I mentioned - this is a Mark II that has been successfully running NeonAI, so it’s a working box. Wondering if the issues that I’m seeing have to do with the updated OS

  • The GUI reacts well, but both restart and shutdown just go into ‘twirly mode’ and never complete.
  • Hey Mycroft does not respond, even after reboot, at least not obviously - no change in the GUI, no audio response. I have not started looking at the logs.
  • Might be a general microphone problem. Just hit the top big button , and got a response that I expected - waiting for input. But no joy when I tried to respond. GUI just sat there, and finally timed out with the “I’m learning new things every day”. I’ve double checked the mic mute button.

What’s the best way to debug this?


Maybe @builderjer knows about that. But there is a PHAL plugin for that:

Definitely a microphone issue. I would re-flash a Raspberry Pi OS Bookworm 64-bit Lite and re-run the installer (just merged the PR).


Just tested the ovos-PHAL-plugin-system and it works except for the services restart but SSH and system restart work.

I just noticed an error with ovos-PHAL-plugin-system. I will try and look into that today.

1 Like

Re-flash an re-install worked. Now I have to peruse the docs to suss out the differences from NeonAI …


1 Like

I just tested it with raspOVOS and the latest packages. Everything seems to be working. SSH, system reboot, system shutdown, and service restart.

I am not seeing the random error message that I saw before. I will keep an eye on it

Service restart doesn’t work for me.

I believe that is because that is a sudo command. Unless your user has access to paswordless sudo, that command probably wont work.

User uses sudo with no password so this is not the issue.

(ovos) goldyfruit@mark2:~ $ sudo -l
Matching Defaults entries for goldyfruit on mark2:
    env_reset, mail_badpass, secure_path=/usr/local/sbin\:/usr/local/bin\:/usr/sbin\:/usr/bin\:/sbin\:/bin, use_pty, env_keep+=NO_AT_BRIDGE, env_keep+=DPKG_DEB_THREADS_MAX, timestamp_type=global, env_keep+="http_proxy HTTP_PROXY",
    env_keep+="https_proxy HTTPS_PROXY", env_keep+="ftp_proxy FTP_PROXY", env_keep+=RSYNC_PROXY, env_keep+="no_proxy NO_PROXY"

User goldyfruit may run the following commands on mark2:
    (ALL : ALL) ALL

Are you running in containers? Maybe that has something to do with it?

It is working fine for me, so hard to debug.