How to install skills on Mark II

I’m an old man with average computer knowledge. I bought a Mark II and waited a year for it to be delivered. I did this b/c I believe it’s very important to have a device that doesn’t act as a spy in our households, and that Mycroft can be such a device for widespread use.
I have the Mark II set up. Now I’d like to install some more skills on it. I’ve read the documentation but don’t see instructions for adding skills. Could someone point me in the right direction?
Thanks very much.


Check out the sandbox images, specifically the “Classic Core” one. If you burn this image to your USB drive, it will boot to the original Mycroft core with support for installing skills.

alternatively, if that sounds too complex, just hang on. This from an earlier thread:
“The production Mark II ships with a custom version of Mycroft Core, known as “Dinkum”. We focused on reliability, which required reworking some of the skill API. Not all skills in the marketplace are compatible yet, but the device does ship with these skills pre-installed:” then it lists the current skills.
Am putting my faith in the keyword “yet:slight_smile: tho am going to try the “classic core” on a seperate usb soon.

I’m not sure I’m understanding what’s happening here. Do I understand that the Mark II shipped without the ability to install additional Skills?

As a user, and one squarely in the middle of the category of potential users of Mycroft who are not expert computer users, I’m representative of the group that will make or break the Mycroft experiment.

Please tell me and my ilk, in plain and direct language, what is going on. We [or at least I] are willing to stick with you, but you must be forthcoming with us.

I’m not comfortable with trying to put a new OS on a $300 machine, especially with the admonition that a mis-step could brick the device.


Just a thought - could Mycroft sell those nice tiny USB drives (with a very small profit) with mycroft-core preinstalled? This way, owners can keep their original Dinkum image intact, and have another “sandbox” USB to play with. I would definitely buy one.

Hope this helps.

-Mike Mac

I’m not sure I understand either. I’ve asked support your specific question (how to install new skills), before I saw your post, but haven’t seen an answer yet. From everything I’ve seen, it does seem that the “dinkum” version of the OS does NOT have the ability to easily add new skills, which to me seems a silly choice to make in the name of reliability, but there you have it. I would like to be wrong about this.

On the other hand, I think you can experiment with other versions of Mycroft (ie., “Classic Core”) without risking your machine. There’s nothing special about the USB drive that came with the Mark II, you should be able to install the Classic Core on your own USB and just physically swap it for the one that came with the Mark II (while it’s shut down), with no risk to the Mark II or the USB that came with it.

1 Like

agreed ecs.
However, I briefly tried the core version. Didn’t get any of the “circular leds” on the mark2 hardware lighting up. Is there somewhere to notify core that its on a mark2 ?
Also the wake word seemed much less sensitive. Asking mycroft for anything seemed to work only about 50% of the time.
Finally, I changed the home screen display, which worked, however on switching back to the dinkum usb found it had switched the homescreen on that as well.
Considering that I didn’t want to make changes to the dinkum device whilst on the core device, I retreated off the core machine.

On my Picroft running on mycroft-core I know you can change something in /etc/mycroft/mycroft.conf to tell it the type of enclosure it’s running on. I would assume that the mycroft-core image for Mark II would already specify the correct enclosure, but could be worth checking. I think it would look something like this:

    "enclosure": {
        "platform": "mycroft_mark_2"

Also I believe at least some skill configurations are synced to your Mycroft account, which is why you can also make changes on the skill configuration page and have them picked up by your device. That probably explains why you saw changes persist between USBs (as opposed to some kind of cross-contamination of the different OSes).

Mounted up the usb I was using for core. Looks like it was set to a Mark1, so will change that to the same as the Mark2 and give that a try.
Good catch finding where its defined, thanks.
As some of these online configurations don’t seem to be seperated by device, was a little concerned that if I made too many changes on the “core device”, may somehow mess up the “dinkum device” (!). Like installing some of the other core skills on the core image, then find that its messed with the config on the dinkum device. Am trying to keep the dinkum device as clean as possible. Will try tho. thanks

1 Like

So to complete @colin answer.
Here is a link of a blog post earlier this month: New Software Options for the Mark II - Mycroft
written by @gez-mycroft (edit correct gez).

How it should work is you say " Hey mycroft install count" and it will install the new skill.
You can see the list of skills in Mycroft Marketplace

I have tried this but mycroft does not seem to understand.

Also one thing I am curious is what the symbols on the skills mean. The Blue Mycroft symbol on the top left it seems to mean it is working on the system. But if it has a green tick next on the top right then the skill does not work. if it has no symbols it clearly does not work. For example I notice that the installer skill has a green tick, and it does not work.

But in contrast, I ask it to tell me a joke but it does not work. So not sure if it this is a rule or a bug.

I have marked this as a bug: Does not tell jokes


Same boat. My chief purpose for buying Mycroft II was to control LIFX bulbs. The Mycroft blog tells me there should be an add button on the skills page. There is no add button for that skill.

I am not about to mess with different software configs…

It would seem that Mycroft II is really a developer tool and not ready for use by the average consumer. So, I have a $399 tool to tell me the weather in the morning …


Hi, @synesthesiam and thanks for your answer, it helped me. I burnt the Classic Core Sandbox on a UBS Stick using Imager SW by Raspberry PI. But when I plug the USB stick into the USB 3.0 right port and start my Mark II it never goes further than the big Mycroft logo covering the screen. I tried it with different USB sticks and they stuck at the same point for booting. Any idea? Thanks a lot.

1 Like

I just tried it out too, and I got the same result of waiting at the Mycroft Logo with “Mycroft AI” underneath it.

Signed up to reply and also be able to follow this thread. I was about to order a Mark II and thought I’d check the forums to get a sense of how it’s performing. I found this thread and am disappointed to see how @geomcd1949 is struggling with no clear guidance from Mycroft. I sort-of fall into the same category as @geomcd1949 and it seems the Mark II may not be appropriate.
Hopefully that will change in the future.

1 Like

Ok i see iam not the only one who didn’t know that the new Firmware on the Mark II Dinkum doesn’t support the expected funktions until now. I understand that this is a project in progress but i thought that there is a bug inside that i can’t install any skill (by voice or by SSH) but now i know why and that is a very bad promotion. At least you tryed to keep the work on it transperent but this most important information the most of us didn’t get! I hope you implement the this function and skills wich are often used on voice assistence in the near future. Otherwise for me this project comes close to the trashcan.


@mike99mac Though we’re not Mycroft, that’s an excellent idea to simplify life for our users. We’ve put a bootable USB up for sale for our Neon AI OS for the Mycroft Mark II. It’s not at a profit, and here’s a link in case you’d like to try it. Thank you for the idea! Neon AI for Mycroft Mark II Bootable USB Drive | Neon AI

1 Like

Thanks, I ordered one and will try it when it arrives.

-Mike Mac
1 Like

Just received Mark II. Boot and wi-fi connection went fine but software is stuck on any attempted skill install request even when shown as compatible. Just loops the light animation on top of the box with no error messaging. (same issue as @amunizp sounds like)

Running v21.2.1

1 Like

Hey @baconneggs I have since learnt that the labeling of the marketplace is slightly out of date.

To see what is compatible (and installed) you have to go to home> skills

I reported the marketplace bug here:


Thank you @amunizp! Yeah, I found that page but the issue I’m having is I can’t install anything new. The default options are mostly just system config skills, hoping there’s a way to install new skills soon.

1 Like