How to install Neon/OVOS natively?

On Neon AI Documentation | Neon AI I read:

The fastest method for getting started with Neon is to run the modules in Docker containers.

It hasn’t been too fast for me :frowning_face:

A dedicated device should do one task. Why does the complexity of Docker need to be added?

Is there a doc on how to flash Neon/OVOS to a USB drive and run it natively on a Pi 4? Thanks.

@mike99mac OVOS provides pre-built images made for a rpi4, but the headless image should run on a pi3b also (not yet tested)

You can write this image to any usb3 drive or ssd drive using the usual raspberry pi imager

There are some docs, with outdated image links, here

With more questions i would like to invite you to our matrix chats


That’s the fastest way to get an instance of the Neon assistant up and running for development. Most of us, OVOS and Neon, develop on Linux. You can install either assistant directly against your system, or sandboxed however you like - I assume, I haven’t actually tried a source install of Neon in a long time - but the Docker deployments are more easily portable, and involve less modification to the host system. This makes them a very popular choice for devs and powerusers, especially for that second and third system you might use for testing your own code against different hardware.

Where the smart speakers are adopting the Docker images, it’s for the same reasons. You are indeed looking at a dedicated device, but it needs the whole Linux stack underneath, which supports Docker. The Assistant spins up and goes whir, and we haven’t identified any performance consequences so far.

Bare installations tend to run the same services that are being containerized by those Docker images, but as regular system services. You can also just execute the constituent parts directly, as regular software. Many avenues are available. Docker is where they kinda meet in the middle.

For your situation, I agree it sounds like you want Builderjer’s link ^ for OVOS/Raspbian on a Pi4. Flash, boot, welcome aboard. I don’t know if Neon currently has a process for DIYers to build their own Neon smart speaker, or if they’re only shipping their OS for the Mark II right now. Let’s ask @NeonClary!


Thank you Chance & Builderjer! Your support is invaluable. Whichever system you prefer is completely fine @mike99mac or even both. :slight_smile:

We’re happy to help you get your project going on Neon. It’s an awesome project, and we’d love to see it be part of the Neon / OVOS ecosystem. Our docs aren’t as far along as we’d like, so best is to get you in touch with @mikejgray and @NeonDaniel so you can get help to supplement the docs, and ideally we can extend the docs as well into the areas you need so that this path is easier for others to follow.

This is a great place for longer / slower exchanges, and we’ve got chats over on Element for more real-time conversations. Are you up for joining in over there? Builderjer shared a link to OVOS’ chat on Matrix Element, and you can find our “rooms” here. There’s also the capacity for private and small group conversations over there.

You can find more of our docs here - About - Neon.AI® Documentation and also readme notes on various parts of the project are here - Neon AI · GitHub

1 Like

Thanks. I had trouble downloading the headless image yesterday, but got it just now. I’ll give it a try :))

the Docker deployments are more easily portable

@ChanceNCounter - thanks for the detailed reply.

I haven’t been able to get goldyfruit’s docker install script to work, but will still try.

I don’t know if Neon currently has a process for DIYers to build their own Neon smart speaker,

I’m working on one on github and have even checked in the G-code for a CNC machine. More on FOSH later…

1 Like

This is a great place for longer / slower exchanges, and we’ve got chats over on Element for more real-time conversations.

You hit on the head with “longer / slower”.

Are you up for joining in over there?

I’ve been over there many times, it’s just the amount of traffic and number of channels overwhelms sometimes. No biggee

1 Like

I flashed it to a microSD, plugged in a monitor, keyboard and mouse and booted.

A Linux came up in line mode and started the install script with the big red (spaceship?).

Then Alan Pope started saying “failed to connect wi-fi. Verify credentials and try again.” about EVERY 5 SECONDS!

The monitor was over-scanned by at least one column and one row which is also annoying.

How to preload the WiFi credentials? Or even edit a file after Linux is up from the command line? Thanks.

We recommend NOT changing the username or WiFi credentials while burning the image.

The images are hardcoded with the user ovos and you setup the WiFi on first boot.

How? I was not prompted for any credentials.

For the headless image, it takes a little over a minute maybe 2 depending on if you use an USB drive or a SSD. The prompt will be something to the effect of “i have created a temporary wifi network called OVOS”

Connect to the OVOS SSID on your phone or laptop. Go to ans enter your wifi credentials there

On the GUI images, including Neon, choose mobile setup from the connection screen and follow the instructions there

I booted again this morning. It never said it created a temporary network. Just Alan Pope repeating “failed to connect to WiFi…” continuously. I killed pulseaudio and thought I had vanquished Alan. But pulse must have re-spawned and he was back: sudo init 0

I look at link to docs you included - seems to document the non-headless version (headful? :)) So maybe I should try that version? It’s probably the more traveled path. I could always turn the GUI off later.

The gui version has an issue i am working on.

How are you burning the image? I have had no issues with it, and several other users are using it now.

The only issue i can see is how the image was burned to the USB? SSD? SDcard? Using imager, etcher, or dd?

@builderjer - I am using Win32 Disk Imager to write to a 64 GB micro SD card. I put it in the RasPi 4 and power on. The fact that Linux boots leads me to assume that process is working.

OK, progress:

  • Burned the gui version to a micro-SD card
  • Booted Linux - I briefly saw the OVOS logo with a nice clean GUI look
  • After a few seconds it fell back to command line
  • Hit the overscan issue - I cannot see the leftmost 7 or 8 characters, nor what I’m typing on the cmd line
  • Tried disable_overscan=0 in config.txt, rebooted, no change
  • Connected to my WiFi with the command sudo nmcli d wifi connect SSID password PASSWD
  • ssh’d in as ovos/ovos from another box (overscan issue worked around :))
  • See I’m running in a (.venv)
  • Say “Hey Ovos” - nothing
  • Say “Hey Mycroft” - got the chime - said “What time is it” - nothing. … “What’s the weather” - nothing :((
  • Try to look at the log file but:
$ cat ./.local/state/mycroft/ovos.log
cat: ./.local/state/mycroft/ovos.log: No such file or directory

So I now have an Ovos system not running on the Mark 2. Is it also Neon?

I’m not worried about the GUI not running as my device will not have a display.

Where are the log files?

Will you try the headless image? I just burned it and it booted exactly as it should. Index of /raspbian/newest/

Neon should boot also. I do not have rhe current link handy though

I am havins some issues with the markII sound at the moment. Usb devices work, and the respeaker devices work

Yes, I’ll try to get to that tomorrow.

Nope, same results, Alan Pope saying no WiFi connection every 5 seconds :frowning_face:

The only other thing I can think of is how it it burned to the USB/SD card. I am a Linux command line user and dd is what I use. I think you said you were using Etcher? Can you try raspberry pi imager and leave all of the default settings. Do NOT change user name and Do NOT try and pre do your wifi credentials. Other than that, I’m not sure what is going on. I have never had that happen.