How to change the wake-up word?

I am using Mycroft in Ubuntu guest on windows host. I want to change the wake-up word. Someone please help me in changing the wake up word…

Hey Acnbot,

Sorry it’s taken a while to respond, we have some documentation outlining our two primary wake word technologies and how to use them:

PocketSphinx is the easiest to get started and only requires text configuration, however Precise will give you a much better experience.

Let us know if you run into problems changing this.

The wakeword can also be changed to one of our supported wakewords through the web graphic interface at:
-> Select Account Tab
-> Devices
-> Your Device
-> Defaults

Select a wakeword. By default we support: Hey Mycroft, Christopher, Hey Ezra and Hey Jarvis.

If you want something more custom like “Nebuchadnezzar” ( which would be awesome because
this ) then follow Gez’s instructions above.

I’d be interested to know how easy you find it to create a new custom wakeword.

I have setup Jarvis as wake up word, and would like to go back to Mycroft to be more ‘standard’. But I’m not able to change it in my account on mycroft’s website. I’m able to change my address, but not the wake word. I also tried to remove my device and pair it again, but the option to chose the wake word is not there anymore.
Any idea?

same thing happened to me after rebooting my pi yesterday. Also, the option to change the wake word was gone from the website.
Found out that somehow the listener was changed to precise.
(logged into the cli and asked,. Then told to change back to PocketSphinx.)
Wake word still didn’t work.
After searching, was able to get mycroft back working by editing the config file using

mycroft-config edit user

and editing to add this
and editing/adding this. Make sure to count the opening {, and that they match the closing }, and that the indentation is in order for the json file to parse.

  "listener": {
    "wake_word": "hey mycroft"
  "hotwords": {
    "hey mycroft": {
      "module": "pocketsphinx",
      "phonemes": "HH EY M AY K R O F T .",
      "threshold": 1e-18

followed these two sites to find out how to set up

and this for the “hey mycroft” phoneme sequence

What is weird is that I didn’t change anything on my local configuration regarding the wake word, shows “Jarvis”, and mycroft-config get gives:

  "listener": {
    "sample_rate": 16000,
    "record_wake_words": false,
    "save_utterances": false,
    "wake_word_upload": {
      "disable": false,
      "url": ""
    "mute_during_output": true,
    "duck_while_listening": 0.3,
    "phoneme_duration": 120,
    "multiplier": 1,
    "energy_ratio": 1.5,
    "wake_word": "hey mycroft",
    "stand_up_word": "wake up",
    "recording_timeout": 10,
    "recording_timeout_with_silence": 3,

  "hotwords": {
    "hey mycroft": {
      "module": "precise",
      "phonemes": "HH EY . M AY K R AO F T",
      "threshold": 1e-90,
      "lang": "en-us"

The options for changing the wake word don’t exist any more in ‘Defaults’. There doesn’t seem to be any way now to change the wake word from the dashboard on

It seems the options have been removed to change the default wake word. This is very disappointing, as I was planning on using Christopher for my project. Does anyone know if this is a glitch or a permanent change?