Have just begun GETTING STARTED and already confused

I tried to carefully follow the instructions for GETTING STARTED, but am confused:

Chose to use Raspberry Pi3 and tried downloading, but somehow got 2 different ZIPs

am burning the first one to microSD, but what is the second ZIP for?

tried searching forum for install help and (again) got confused when a post said to use:
sudo apt-get install mycroft-core

I thought that was taken care of by burning
onto the microSD card

The raspbian-stretch_Picroft_2018-09-12.zip is the one you have to burn on sd card.
When you then bootup the pi it is allreddy installed whith mycroft and auto start him. Just follow instruktions on console (or if you ssh into him)

About apt-get install mycroft-core - tht is when you do install of mycroft manualy on a Linux box.

1 Like


What @andlo said :wink: (many thanks for such a quick response!)
Let us know if it’s still not working for you, and apologies for the confusion.

The Picroft documentation is also worth a read.

I flashed raspbian-stretch_Picroft_2018-09-12 four times now, and I keep getting the same errors after the first power up or whenever I try mycroft-mic-test

Traceback (most recent call last):
File “/usr/lib/python3.5/runpy.py”, line 193, in _run_module_as_main
main”, mod_spec)
File “/usr/lib/python3.5/runpy.py”, line 85, in _run_code
exec(code, run_globals)
File “/home/pi/mycroft-core/mycroft/util/audio_test.py”, line 102, in
File “/home/pi/mycroft-core/mycroft/util/audio_test.py”, line 89, in main
record(args.filename, args.duration)
File “/home/pi/mycroft-core/mycroft/util/audio_test.py”, line 64, in record
with mic as source:
File “/home/pi/mycroft-core/mycroft/client/speech/mic.py”, line 122, in enter
input=True, # stream is an input stream
File "/home/pi/mycroft-core/.venv/lib/python3.5/site-packages/pyaudio.py, line 750, in open
stream = Stream(self, *args, **kwargs)
File "/home/pi/mycroft-core/.venv/lib/python3.5/site-packages/pyaudio.py, line 441, in init
self._stream = pa.open(**arguments)
OSError: [Errno -9997] Invalid sample rate

If I type in what time, I get the correct local time displayed as text on my TV (used instead of an actual computer monitor). The time is also heard as the TTS voice from the TV speakers.

I can enter the (.venv) pi@picroft:~ $ prompt by hitting CTRL-C

Whenever I try mycroft-setup-wizzard the display reads:
-bash: mycroft-setup-wizzard: command not found

On this forum page:

there was a link for audio troubleshooting:

The first step of the troubleshooter, pacmd list-sources, made this come up:
-bash pacmd; command not found

I played around with aplay and arecord, and was able to demonstrate that the mic, USB sound card, and the RPi3B were all in working order. I was able to take the stream from the mic and pipe it to the HDMI output, so as to be heard through the TV speakers. My project is (hopefully) to run headless, so the USB sound card will do both mic input and speaker output simultaneously. I tried use pipes again but I still have a lot to learn (the mono mic iinput and the stereo output were the problem - I think).
This, however, is me getting sidetracked. I really need to get Picroft to hear what the mic picks up, but I was never able to get the on-screen mic level meter to register at all. I couldn’t even get going with the documentation’s instructions
I really hope I can get on track because it would be cool to write skills to interface with a couple of Arduino projects I made.


Hi Darren, I did a bit of digging on this issue, specifically the error
OSError: [Errno -9997] Invalid sample rate

It points to an incorrect device being selected.

Try running mycroft-setup-wizard - note the single z, not the double z.

Hi Kathy,

Thanks so much for the help. I’m just going to get the ** PlayStation Eye** and save some aggravation - and save having to learn alsa, PulseAudio, asoundrc, jackd, linux …!

I can’t spell WIZZARD! Thanks for paying attention, I just now was able to successfully run the wizard. Sorry about such a sloppy mistake.

The part I mentioned from above:
** The first step of the troubleshooter, pacmd list-sources , made this come up:
-bash pacmd; command not found**

I’m still getting this error (I re-downloaded the Picroft IMG, and used Etcher this time to flash the microSD card). Could this be because I haven’t installed the microphone yet? I want to fix all the problems I’ve created before going forward (and buying the mic).

Thanks again

No worries at all, I have linux command line eagle eyes :tm: :wink:

I actually think this is because PulseAudio may not be installed. The command pacmd is installed as part of PulseAudio.

Different plan, can you run alsamixer?

Best, Kathy

Hey Kathy!
I have the same problem as Beavis.
But I’m confused.
The issue you referenced did not tell me how to rectify it on mycroft.
And do I do sudo apt-get install pulseaudio to get PulseAudio?

Yes, to install pulseaudio, run the command;

sudo apt-get install pulseaudio

This assumes you’re on a Debian installation or Debian-like system, like Ubuntu, or Raspbian.
Your installation might be different if you’re on another type of Linux.

Hey everyone! This is my first time fooling around with any of this stuff and I just got my RPi3 booted up and ready to go on Raspian. Is it a good idea to flash the Picroft img on this same SD card. I’ve been nervous about doing this incorrectly and then having to redo everything all over again. I’m still waiting on my PS3 Eye cam to come in so there hasn’t been a rush to try anything out yet. Thanks :slight_smile:

If you don’t want to mess with your existing Raspbian SD card, I would recommend getting a second SD card and flash the Picroft Image so you can play with that.

1 Like

I say as @pcwii to get another sd card. And do get used to how to flash a SD card, as it is something you will do fom time to time. It is nice to know how to start over if one is to mess everything up :slight_smile: and that is where flashing the SD card is what to do.
Using a program like Etcher you cant really do it wrong.There are three buttons, one for selecting the image, one for selecting the SD card and one for starting to flash.

1 Like

Awesome just wanted to be sure. Been getting the hang of everything. Etcher is real quick and easy to use. I even stumbled upon a program called PiBakery that lets you preconfig the pie before booting :+1:t5: