Google cloud STT transcribing problems

I have trained my own precise wake word and using google STT, however, It is just not recognizing my audio inputs. I have generated a new access token and applied it in Mycroft config user. any help would be much appreciated!

06:39:08.400 | INFO | 21331 | main:handle_wakeword:67 | Wakeword Detected: ok poli
06:39:08.780 | INFO | 21331 | main:handle_record_begin:37 | Begin Recording…
06:39:11.796 | INFO | 21331 | main:handle_record_end:45 | End Recording…
06:39:11.806 | INFO | 21331 | googleapiclient.discovery | URL being requested: GET
06:39:12.161 | INFO | 21331 | googleapiclient.discovery | URL being requested: POST
06:39:12.161 | INFO | 21331 | oauth2client.transport | Attempting refresh to obtain initial access_token
06:39:12.162 | INFO | 21331 | oauth2client.client | Refreshing access_token
06:39:13.013 | ERROR | 21331 | mycroft.client.speech.listener:transcribe:239 |
06:39:13.013 | ERROR | 21331 | mycroft.client.speech.listener:transcribe:240 | Speech Recognition could not understand audio

Hi Deepak,

Can you post what you have for your user config? Without the access token of course.

Hi Gez,

thanks for helping! I also checked on google cloud, the queries I think are going through to the cloud…but here is what i currently have on the user config:

“max_allowed_core_version”: 20.2,
“lang”: “en-us”,
“stt”: {
“google_cloud”: {
“lang”: “en-us”,
“credential”: {
“json”: {
“type”: “service_account”,
“project_id”: “mycroft-cs”,
“private_key_id”: “”,
“private_key”: “-----BEGIN PRIVATE KEY-----”
“client_email”: “”,
“client_id”: “xxxxcc”,
“auth_uri”: “”,
“token_uri”: “”,
“auth_provider_x509_cert_url”: “”,
“client_x509_cert_url”: “
“module”: “google_cloud”
“listener”: {
“wake_word”: “ok poli”
“hotwords”: {
“ok poli”: {
“module”: “precise”,
“local_model_file”: “/home/parallels/.mycroft/precise/ok-polly.pb”

Hmmm, the only things that seem wrong are the quotation marks being non-standard, but think that’s most likely Discourse changing them.

And there’s a comma missing at the end of private_key but I assume that’s just from deleting the majority of the line?

Can you try updating the google-api-python-client pip package?
If you have the helper commands it’s just:

mycroft-pip install google-api-python-client==1.9.1


source ~/mycroft-core/.venv/bin/activate
pip3 install google-api-python-client==1.9.1

Yes the quoetes are single in the user configs, and there a comma after the private key.
I updated the google api client, it is till not working, and it is still not working…

I also noticed something strange with the mic levels in the CLI…the levels run perfectly in general, and pick up my custom wake word. However the level goes very low almost to 3-10 when recording my utterance after the wakeword. i tried reinsatalling pulse audio, I checked the levels with the alsa mixer, everything seems to be working, but this seems to be the only glitch i have noticed.