Google AIY VoiceKit 2 with Raspberry Pi 4 B

Hello Everyone,

I was trying to install picroft on Raspberry Pi 4B + Google AIY VoiceKit 2. But I can’t get the audio input & output working. I’ve tried and it’s not working. Can anybody help me fix it?

Hi Toms!

The skill you tried to installed requires a working Google AIY VoiceKit 2. If it’s not the case then this skill will be useless until then.

During the wizard (at the first boot), did you choose the following?

4) Google AIY Voice HAT and microphone board (Voice Kit v1)

This should should install the required packages from Google and configure your Raspberry Pi properly. At the end a reboot is required.

1 Like

Thanks a lot for the quick response. I didn’t choose that option as I have Voice Kit V2.

Did you run this shell script:

Yeah. I ran it too. No luck

Fixed the issue.

Installed Chiisaa skill from marketplace and installed it. The LED was workinf fine after that, but not the audio input & output. Finally went to /boot/config.txt and commented out the below lines.




works like a charm now.

If you face any issues setting up Raspberry Pi4B + AIY Voice Kit V2, feel free to post in this thread so I can help.


Thanks :slight_smile:

I was wondering how the AIY Voice Kit V2 is working out for you? Does it pick up you talking and commanding mycroft well? Is it better or worse than other mics you’ve tried?

Thanks for the info.