Git clone on Raspberry Pi3

Has anyone tried a Git clone on Raspberry Pi3 ? I dont want to flash my SD card and install Picroft.
It is stuck for a real long time during mimic install after which it throws an error. Below is my trace of ./
Any help is greatly appreciated.

      CC       lang/vid_gb_ap/libttsmimic_lang_vid_gb_ap_la-vid_gb_ap_cg_10_durmodel.lo
      CC       lang/vid_gb_ap/libttsmimic_lang_vid_gb_ap_la-vid_gb_ap_cg_12_mcep_trees.lo
      CC       lang/vid_gb_ap/libttsmimic_lang_vid_gb_ap_la-vid_gb_ap_cg_12_params.lo
      CC       lang/vid_gb_ap/libttsmimic_lang_vid_gb_ap_la-vid_gb_ap_cg_17_durmodel.lo
      CC       lang/vid_gb_ap/libttsmimic_lang_vid_gb_ap_la-vid_gb_ap_cg_17_mcep_trees.lo
      CC       lang/vid_gb_ap/libttsmimic_lang_vid_gb_ap_la-vid_gb_ap_cg_17_params.lo
    gcc: internal compiler error: Killed (program cc1)
    Please submit a full bug report,
    with preprocessed source if appropriate.
    See <file:///usr/share/doc/gcc-4.9/README.Bugs> for instructions.
    Makefile:3876: recipe for target 'lang/vid_gb_ap/libttsmimic_lang_vid_gb_ap_la-vid_gb_ap_cg_12_params.lo' failed
    make[1]: *** [lang/vid_gb_ap/libttsmimic_lang_vid_gb_ap_la-vid_gb_ap_cg_12_params.lo] Error 1
    make[1]: *** Waiting for unfinished jobs....

Hi, since mimic, compilation on RPi3 fails due to a lake of memory. The solution is to increase the swap file on the Raspberry. Just edit /etc/dphys-swapfile and increase CONF_SWAPSIZE variable to 512 or 1024, reboot and run ./ again. It will take a while but it works. You can then return to the original value if you need space on your sd card.

1 Like

Its still working , but I am hopeful. It proceeded past the error. You are a SAVIOR. Thank you sooo much!
Update : Worked like a charm.

Thanks, you’re welcome !