Getting Started in Ubuntu - Development Environment

Hi Mycroft Party Peeps,

I’m trying to setup the development environment in Ubuntu and I’m stuck at the following stages in the README:

  1. Are the config files described in the README automatically generated

  2. How do I start the virtualenv? The workon command doesn’t work, I get the error message “workon: command not found”. I’m in the root of my mycroft clone folder

Many thanks,
Dr H.

i’m stuck with same thing. are you resolved?

Make sure that you have virtualenv and virtualenvwrapper installed, first and foremost. The default.ini config file exists in the project, but the other files are note generated by default. Creating either of them will result in them being looked at before the default.

Make sure to run the dev setup script.

What distro are you on? Ubuntu? Raspbian?

Same here on Ubuntu 16.04 :

workon: command not found

(I obviously ran before :wink: )

I don’t find defaults.ini file in the mycroft repo :innocent:

@DarkSide they are in Mycroft/Mycroft/configuration/defaults/ (not actually looking at the project right now, but pretty sure that is the location. Let me follow up in a bit.

1 Like

@ryanleesipes Yes, I found it ! Thanks Ryan !

Now, the workon: command not found problem… I hope I will find a solution after my work day. :wink:

It works now. I just restarted my Ubuntu ^^.

So, the procedure :

cd <path_to_mycroft_repo>/mycroft ./ sudo apt-get install curl espeak libssl-dev ./

Restart your OS and then

cd <path_to_mycroft_repo>/mycroft workon mycroft


1 Like

Oh yes, I’ve ran into this every time I have set stuff up. That is going into the README.

Hey thanks! I ran into that probem too. I have been too busy lately to get a chance to trouble shoot it. That was the first issue I ran into.

I had a question, after compilation and set up how do we interface with the AI? Do we start with the terminal badh shell? Or does it automaticly respond to voice commands? If I were to put in the IP of my virtual machine (ubuntu) into a web browser, would I bee able to go to a simple web page to login and setup / configure the system? Do you have any videos of how you bring up the servies and interface while you are testing your system?

Open 3 terminals in the Mycroft checkout dir:
Terminal 1
./ service
Terminal 2
./ skills
Terminal 3
./ voice

If you want them to background in one terminal use &;
./ service &

Expect this to get better :wink:

1 Like

after those services are started, can you enter questions to it via text in a bash shell? or does it have to be through voice activation only?

@aatchison That’s exactly what I did and my first request was “Mycroft, tell me a joke”. I was not disappointed. :smile:
It made me laugh :grin:

Good question, I also wander how to interact with Skills without using the voice ?

There is also:
./ cli --quiet

1 Like

ok cool thanks, i will have to check that out once i get some more time on my hands.

Sorry to appear absolutely clueless (which I am) but what is meant by the Mycroft ‘checkout’ directory?

The checkout directory is just the folder where you downloaded mycroft-core. :slight_smile:

ah, thanks, makes sense I guess cheers!

I resolved this with help from the Slack channel. I had setup the environment as sudo. I re-ran as my normal user and this fixed everything.