Getting No Audio Output in Picroft

A week ago I was tuning in to the Bad Voltage digital broadcast and chose to uncover it back. I introduced the March fourteenth picture. It is by all accounts more joyful, yet I am battling with getting the gadget to utilize the Jabra as the speaker.

I can tell from the logs that the mouthpiece is working (couldn’t motivate that to happen last time, along these lines, yahoo) however no yield. I’ve attempted basically everything suggested on the intertoobz, including altering the mycroft.conf document and including (and expelling) different .asoundrc records. I’ve additionally disturbed the alsamixer order to ensure the yield is set legitimately and not quieted.

Note that in the event that I run “talk hi” on the CLI, the dulcet tones of Alan Pope get through the speaker fine and dandy. On the off chance that I run “aplay [wav file]” I hear the yield fine and dandy.

Hi there @alexbach, thanks for joining us and giving Picroft a go.

Are there any error messages in your voice.log or audio.log which might provide clues as to the cause?

You can find logs at /var/log/mycroft.

Kind regards,

Ummm… I don’t seem to find any log file. :sweat_smile: :sweat_smile:

What does the output of
ls -las /var/log/mycroft/ show?

/var/log/mycroft $ ls -al
total 121932
drwxrwxrwx 2 root root      4096 Oct 21 12:12 .
drwxr-xr-x 5 root root      4096 Nov 12 06:25 ..
-rw-r--r-- 1 pi   pi      608211 Nov 12 11:18 audio.log
-rw-r--r-- 1 pi   pi       29115 Nov  9 10:06 bus.log
-rw-r--r-- 1 pi   pi   123634065 Nov 12 11:22 skills.log
-rw-r--r-- 1 pi   pi      550784 Nov 12 11:17 voice.log


What is the output of the command;

cat /var/log/mycroft/audio.log | grep -i error


cat /var/log/mycroft/voice.log | grep -i error

I need to see the log entries to assist with diagnostics.

Where would I find them?

Check this code.
// Mechanism used to play WAV audio files
// Override: SYSTEM
“play_wav_cmdline”: “paplay %1 --stream-name=mycroft-voice”
Is this your wav audio files?

1 Like

I found these two sources related to my question.

Do you think I should explore this thread more or contact the support team?

Hi @alexbach, how did you go getting your voice.log and your audio.log?
The commands I provided previously, which should be run on the Picroft terminal (if you’re in the Mycroft CLI, do Ctrl + C to get out of the terminal), should show whether there are any errors in these log files, and will help us diagnose the issue.

If you contact Support, they will ask exactly the same question …

1 Like

This is very much confusing. I was trying to get my hands on the technology but I don’t think I have enough caliber to do so…

Do you have any related video that can help me out?

I think you should understand the whole problem through this discussion. It has enough resources to fix your issue.

1 Like

I had the exact same problem with the Jabra 510 (same as 410 but with bluetooth capability). There appears to be a problem in the raspian-stretch_Picroft_2018_09-12 distribution, because it appears to not have pulseaudio installed in the distribution. I’ve tried to use the wizard and go straight to the command line, but in both cases pulseaudio was not installed (dpkg -l does not show it). The claim on is that pulseaudio is used, but that is either false or else the build has omitted pulseaudio.

Hi @kevinmccurley, thanks for your feedback.

We’re currently in the process of updating the Picroft documentation, and you’re right, the Lightning version of Picroft did not included pulseaudio, however we’ve found that it tends to work a lot better with pulseaudio installed, so we’re currently testing a PR that will include it again.

Just reboot your Picroft to pick up the change.

I think your system is crashed. You should use IP and you should reinstall it…