Found how to install third party but is not working

msm install
####### Mycroft Skill Manager #######
Attempting to install
Cloning repository
Cloning into ‘mycroft—movie-recommend-skill’…
remote: Counting objects: 71, done.
remote: Total 71 (delta 0), reused 0 (delta 0), pack-reused 71
Unpacking objects: 100% (71/71), done.
Checking connectivity… done.
Installing libraries requirements
/usr/local/bin/msm: line 140: workon: command not found
Unable to activate mycroft virtualenv!
/usr/local/bin/msm: line 148: deactivate: command not found
Sorry I’m unable to complete the request! Check the error messages above for why. Err 120

I did found the way to install manually… so for the mean time is ok… but we should change msm to adapt to the enviroment and device.

You might need the virtualenv wrapper or activate virtualenv before installing the skill, see

why will I want to use virtualenv or docker etc on a prod device, this is not in a developer workstation
I hate running python with its plugins on virtual pip setups, instead of using system apt-get* or at least pip install on the main OS. I am a systems engineer and we hate when some developers give us their setups/pre like if they were local to their work station… lol then is hell to keep the whole OS in sync with upstream. Not to say when you run security updates it does not take into acount non-system gems or python libs… that are not installed in the system… such this is why so many websites get hacked because dev do not update their plugins and system engineers do not even know they are installed since they are in userspace. Like locally if I am developing a webapp yes… then makes sense to use virtualization and such to test things with diff version of libs or even future libs not yet preinstalled in debian/ubuntu/fedora etc.

i am just saying that your error messages indicate that you should do this to get the skill running :slight_smile:

:slight_smile: I got that… but seems to me most of the software is ready for dev machines and not the mark1 device yet… so they should fix it so is not needed to run with virtual setups but with the raspian OS

There’s an issue open for this on git already.

If you want you can try the updated version linked at the bottom of that post and see if it helps.

You shouldn’t need to install virtualenv on picroft or mk1 just for skills, unless the skill calls out for them specifically.

1 Like

Just wondering if this issue is back, or if there’s another workaround? I’ve been googling for a while and coming up blank.

I have Mycroft running via the mycroft-core package. It shares a Raspbian install with my HomeAssistant instance. Today I was trying to debug why some skills work and others don’t. I discovered that msm fails to install a bunch of requirements, even for default skills, because of this error.

If there needs to be a virtualenv, I’d have thought mycroft-core would set one up.

Where should I file an issue? I don’t doubt that this would work if I set up a virtualenv correctly, but I’m not sure how to do that in the context of the mycroft-core package, and someone should probably be notified that the installation of these gives very inconsistent results. I’ve been scratching my head for a while trying to figure out why Mycroft could successfully set an alarm but failed to know what time it was. :stuck_out_tongue:

@ndarilek can you try installing the mycroft-picroft package instead of the plain mycroft-core package

I saw the github issue is closed on months ago, but I’ve just tried to install a skill with MSM on Mark1 and it doesn’t work

 msm install fallback
parse error: Invalid numeric literal at line 19, column 11
parse error: Invalid numeric literal at line 19, column 11
ERROR: Unable to find/access !

In fact, just executing msm does the same

parse error: Invalid numeric literal at line 19, column 11
parse error: Invalid numeric literal at line 19, column 11
ERROR: Unable to find/access !

I’m on mycroft core 0.9.8 by the way. Never tried before.

I found the problem, by executing the JSON parser found the same error

 jq -r  '.enclosure.skill_folder' /etc/mycroft/mycroft.conf
parse error: Invalid numeric literal at line 19, column 11

So, taking a look into /etc/mycroft/mycroft.conf I saw that in line 19 there was a comment (i.e. a line starting with // ).
Deleting the entire commented line, now msm seems to run :slight_smile: