First installation: connection error and few question

Hi all,

I’m trying Mycroft for the first time and I want to use the mycroft web client, however when I launch the mycroft debug I get this error: “ConnectionRefusedError: [Errno 111] Connection refused”

The mycroft messagebus websocket are the default ones:

// The mycroft-core messagebus’ websocket
“websocket”: {
“host”: “”,
“port”: 8181,
“route”: “/core”,
“ssl”: false

I’ve disabled the firewall
What I can look for? I need to say that I’ve installed mycroft on my vps,but this should be a problem right?

I think host needs to be something other than


I’ve already tried with different hosts, like or localhost, same error.
In theory should be fine, this means that the listening socket is reachable from all interfaces including the local network.

I’ve also tested the 8181 port with a simple client/server python script and is working, so port is not blocked or already used

The on GitHub says „…MYCROFT_IP_ADRESS … (Not localhost)“. Did you try the Network IP-Address (which is not

The readme is very terse, but I’m pretty sure that MYCROFT_IP_ADRESS is the machine address where I’ve installed mycroft and should expose the web interface, in my case is a vps so I’ve a static ip where point to with the browser…this piece should be already correct.

What I think is not working is the messagebus websocket which the configuration is the one posted above, in the file: mycroft-core/mycroft/configuration/mycroft.conf

I’m not sure if is the cause (I’m a webdev but never touched python code) but looking at the log I’ve noticed a lot of errors in, probably because I’m using python 3.5 and the code is for 2.X…did anyone even managed to run this script?

Did you resolve the connection issue?
I am getting the message: “ConnectionRefusedError: [Errno 111] Connection refused”

ConnectionRefusedError: [Errno 111] Connection refused 23:34:22.239 - - ERROR - Exception closing websocket: Exception(“Uncaught ‘error’ event.”,)
23:34:22.240 - - WARNING - WS Client will reconnect in 60 seconds.

Hi @David, this means the mycroft-* services are not running.

In your mycroft-core installation, try running ./ debug.

Hi @Kathy, After reinstalling mycroft-core and updating linux,
mycroft-core is now connected to the messagebus and
I have successfully communicated with Mycroft-Android running on my phone.

1 Like

Fantastic, thanks for confirming!