Fatal Error When Installing

I have two problems. One is that the script keeps installing pip 2.0.2 over my already installed 2.2.2.
So perhaps this is the problem leading to this error

**gcc:**   **fatal error:** Killed signal terminated program cc1
compilation terminated.
make[1]: *** [Makefile:4068: lang/vid_gb_ap/libttsmimic_lang_vid_gb_ap_la-vid_gb_ap_cg_01_params.lo] Error 1
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory '/home/aryan/mycroft-core/mimic'
make: *** [Makefile:4319: all-recursive] Error 1

    ERROR: Command erroredout with exit status 1:
        command: /home/aryan/mycroft-core/.venv/bin/python -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-q1llz2
    hw/fann2/setup.py'"'"'; __file__='"'"'/tmp/pip-install-q1llz2hw/fann2/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file__);
    code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' egg_info --egg-base /tmp/pi
            cwd: /tmp/pip-install-q1llz2hw/fann2/                                                                                           
       Complete output (10 lines):                                                                                                          
       Traceback (most recent call last):                                                                                                   
         File "<string>", line 1, in <module>                                                                                               
         File "/tmp/pip-install-q1llz2hw/fann2/setup.py", line 65, in <module>                                                              
         File "/tmp/pip-install-q1llz2hw/fann2/setup.py", line 60, in build_swig                                                            
           swig_bin = find_swig()                                                                                                           
         File "/tmp/pip-install-q1llz2hw/fann2/setup.py", line 55, in find_swig                                                             
           raise Exception("Couldn't find swig2.0 binary!")                                                                                 
       Exception: Couldn't find swig2.0 binary!                                                                                             
       running swig                                                                                                                         
    ERROR: Command errored out with exit status 1: python setup.py egg_info Check the logs for full command output.

these are the two errors.

And this as well. 
ERROR: Command errored out with exit status 1:
    command: /home/aryan/mycroft-core/.venv/bin/python -u -c 'import sys, setuptools, tokenize; sys.argv[0] = '"'"'/tmp/pip-install-onf
1sdw5/fann2/setup.py'"'"'; __file__='"'"'/tmp/pip-install-onf1sdw5/fann2/setup.py'"'"';f=getattr(tokenize, '"'"'open'"'"', open)(__file_
_);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec'"'"'))' install --record /tmp/pi
p-record-u3xmk94n/install-record.txt --single-version-externally-managed --compile --install-headers /home/aryan/mycroft-core/.venv/incl
        cwd: /tmp/pip-install-onf1sdw5/fann2/                                                                                           
   Complete output (28 lines):                                                                                                          
   running swig                                                                                                                         
   running install                                                                                                                      
   running build                                                                                                                        
   running build_py                                                                                                                     
   creating build                                                                                                                       
   creating build/lib.linux-x86_64-3.8                                                                                                  
   creating build/lib.linux-x86_64-3.8/fann2                                                                                            
   copying fann2/__init__.py -> build/lib.linux-x86_64-3.8/fann2                                                                        
   copying fann2/libfann.py -> build/lib.linux-x86_64-3.8/fann2                                                                         
   running egg_info                                                                                                                     
   writing fann2.egg-info/PKG-INFO                                                                                                      
   writing dependency_links to fann2.egg-info/dependency_links.txt                                                                      
   writing top-level names to fann2.egg-info/top_level.txt                                                                              
   reading manifest file 'fann2.egg-info/SOURCES.txt'                                                                                   
   reading manifest template 'MANIFEST.in'                                                                                              
   writing manifest file 'fann2.egg-info/SOURCES.txt'                                                                                   
   copying fann2/fann2.i -> build/lib.linux-x86_64-3.8/fann2                                                                            
   copying fann2/fann2_wrap.cxx -> build/lib.linux-x86_64-3.8/fann2                                                                     
   copying fann2/fann_cpp_subclass.h -> build/lib.linux-x86_64-3.8/fann2                                                                
   running build_ext                                                                                                                    
   building 'fann2._libfann' extension                                                                                                  
   creating build/temp.linux-x86_64-3.8                                                                                                 
   creating build/temp.linux-x86_64-3.8/fann2                                                                                           
   gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -fno-se
mantic-interposition -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -march=x86-64 -mtune=generic -O3 -pipe -fno-plt -fPIC -DSWIG_COMPIL
E -I./include -I../include -Iinclude -I/home/aryan/mycroft-core/.venv/include -I/usr/include/python3.8 -c fann2/fann2_wrap.cxx -o build/
   g++ -pthread -shared -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -fno-semantic-interposition -Wl,-O1,--sort-common,--as-needed
,-z,relro,-z,now build/temp.linux-x86_64-3.8/fann2/fann2_wrap.o -L/usr/lib -ldoublefann -o build/lib.linux-x86_64-3.8/fann2/_libfann.cpy
   /usr/bin/ld: cannot find -ldoublefann                                                                                                
   collect2: error: ld returned 1 exit status                                                                                           
   error: command '/usr/bin/g++' failed with exit code 1                                                                                
ERROR: Command errored out with exit status 1: /home/aryan/mycroft-core/.venv/bin/python -u -c 'import sys, setuptools, tokenize; sys.ar
gv[0] = '"'"'/tmp/pip-install-onf1sdw5/fann2/setup.py'"'"'; __file__='"'"'/tmp/pip-install-onf1sdw5/fann2/setup.py'"'"';f=getattr(tokeni
ze, '"'"'open'"'"', open)(__file__);code=f.read().replace('"'"'\r\n'"'"', '"'"'\n'"'"');f.close();exec(compile(code, __file__, '"'"'exec
'"'"'))' install --record /tmp/pip-record-u3xmk94n/install-record.txt --single-version-externally-managed --compile --install-headers /h
ome/aryan/mycroft-core/.venv/include/site/python3.8/fann2 Check the logs for full command output.

Hi, what os are you running on?

The mimic error could be an out of memory issue or out of tmp diskspace. You can try editing the dev_setup.h L539 making it MAXCORES=1 which should limit the memory usage.

The second error indicates that libfann2 can’t be found, dev_setup.sh should have installed it…

and while you’re at it install swig >=2

1 Like

I’m running manjaro. How much space does mycroft need?
Thank You

How would I solve the other problem about pip. I have pip 20.2.2 installed but the script still asks me to upgrade it

The Arch installation uses libfann which was removed from AUR. Therefore, it should be replaced with fann

That’s not a real issue. Pip just informs that there is a new version available (we lock the pip version since upgrades of Pip has broken dev_setup.sh in the past)

any idea how I do this manually

Do you mean upgrading pip or installing fann?

it seems to be done already on the dev_setup.sh so i don’t why it’s showing the error

I know to install it but how do make it use fann instead of libfann

Sorry I know to little of arch/manjaro to help out here :frowning:

Thank you very much anyway. I’m trying it again and will close this conversation if it’s suscessful

Oh my god! You solved it, I’ll just swap that with the actual active one. Perhaps you could make this change a real thing? https://aur.archlinux.org/packages/fann/

No that happens to me as well

Just noticed the gitrepo the script tries to pull gives a 404: https://aur.archlinux.org/fann.git

Edit: false alert, just my proxy acting up

1 Like

If the package is directly available in the repo we should definitely use it instead of building locally. The arch / manjaro install is community contributed, none of the Mycroft devs uses it so if you can get it up and running feel free to make a PR updating it. Or open an issue on github so it’s tracked.

Hello, I have been trying to get Mycroft installed on my Windows computer and am getting a very similar error about swig 2.0 binary being “missing”. I tried reinstalling the required packages and Mycroft itself but nothing seems to be working. I can’t create a new post for some reason, and this is the most similar post I could find.

error: subprocess-exited-with-error

× python setup.py egg_info did not run successfully.
│ exit code: 1
╰─> [11 lines of output]
Traceback (most recent call last):
File “”, line 2, in
File “”, line 34, in
File “C:\Users\ashna\AppData\Local\Temp\pip-install-2ccz9j5y\fann2_28dcce4c70124a02acb6e67824758ddc\setup.py”, line 65, in
File “C:\Users\ashna\AppData\Local\Temp\pip-install-2ccz9j5y\fann2_28dcce4c70124a02acb6e67824758ddc\setup.py”, line 60, in build_swig
swig_bin = find_swig()
File “C:\Users\ashna\AppData\Local\Temp\pip-install-2ccz9j5y\fann2_28dcce4c70124a02acb6e67824758ddc\setup.py”, line 55, in find_swig
raise Exception(“Couldn’t find swig2.0 binary!”)
Exception: Couldn’t find swig2.0 binary!
running swig
[end of output]

note: This error originates from a subprocess, and is likely not a problem with pip.
error: metadata-generation-failed

× Encountered error while generating package metadata.
╰─> See above for output.

note: This is an issue with the package mentioned above, not pip.
hint: See above for details.

Does anyone have any idea on how to solve this? I have no experience with Mycroft (because of this problem), so I can’t really figure out any solution. I honestly don’t even know if this post will be seen since this reply is three years after the last reply, but here goes.


It sounds like you’re using the classic Mycroft-core package on Windows, which isn’t likely to work for a couple reasons:

  • It isn’t Windows software. A few of us have run it on Windows over the years by various means, but most of us used WSL, rather than trying to run it natively
  • As far as I know, all remaining Mycroft-based projects are based on a fork. These forums are in use by surviving descendant projects, who might have what you’re looking for (I hope so!) but the original repository is abandonware.

There should be a FAQ pinned to the front of these forums, but removing it from my own feed appears to have hidden it from everyone’s feed. Very sorry! You should have been spared this experience. I think I’ve fixed it, but I’m on my phone, and I guess I’ll need to check from a PC to know if I’m seeing what you’re seeing.