Failed to find intent on Arch Linux

I am trying to run Mycroft on Arch on my laptop. I used a modified PKGBUILD to install v18.8.10, and now I can’t get it to run properly. The start script runs without errors but on launching mycroft-cli-client, and giving any input, I get:

18:53:32.400 - __main__:handle_complete_intent_failure:82 - INFO - Failed to find intent.
18:53:32.397 - mycroft.skills.core:handler:1529 - WARNING - No fallback could handle intent.

And a response:

>> Please wait a moment as I finish booting up.

After giving 2-3 inputs, this also appears in the logs:

~~~~:438 - WARNING - Could not get device infO: ReadTimeout(ReadTimeoutError("HTTPSConnectionPool(host='', port=443): Read timed out. (read timeout=3.05)"))

But this might be unrelated, as it appears in voice.log and may be caused by too quickly passed inputs.

What should I do?

Hi @aksh1618

Am I right in thinking that it hasn’t prompted you to pair the device with yet?

Yes, @gez-mycroft, no such prompt. Nothing happens on starting.

Hi @aksh1618
I just want to eliminate some of the possibilities and see what else we can find.

  • Are you behind any kind of proxy or firewall?
  • Have you tried to run this again since Jan 18? In case just happened to be unavailable at that moment.
  • Does the /opt/mycroft/skills/mycroft-pairing.mycroftai directory exist?
  • As there was an intent failure, is there anything else of interest in /var/log/mycroft/skills.log?

Where did you get the modified PKGBUILD from?

Hey @gez-mycroft, thanks for helping!

  • I have firewall enabled normally, but disabled it while running mycroft.
  • I tried running right now, faced the same issue.
  • No, /opt/mycroft/skills/mycroft-pairing.mycroftai doesn’t exist. So I symlinked /opt/mycroft to /usr/share/mycroft-core/mycroft, and we have progress!

Running mycroft-cli-client now ran a lot of commands, but is now stuck at pairing. It isn’t showing any codes. How do I get the pairing code?

Also, this keeps popping up:

msm.mycroft_skills_manager - ERROR - Error running install_or_update on mycroft-pairing: PipRequirementsException(
        Pip returned code 2:

        Permission denied while installing pip dependencies. Please run in virtualenv or use sudo

How do I make it run in virtualenv? Where should I create it?

I editted the PKGBUILD available at to get the latest version at that time, 18.8.10.

Hey, great to hear we have progress!

To enter the virtual environment head to your mycroft-core directory and run source

Is the mycroft-pairing.mycroftai skill in /usr/share/mycroft-core/mycroft/skills?
If not you can download it directly from