Error running for Mycroft GUI

Hi, it’s my first time using Mycroft.
I’m running Manjaro and have set up Mycroft-core, so now I’m trying to set up mycroft-gui. I have cloned the repo.
The problem I have arises when I run `bash, I get to select my distro, after which I am requested for my password, and after that, it seems like it installs the dependencies, but then I get an infinite Enter a number (default=1): error: invalid number: y. This goes on forever until I send ^C, but I can’t go up enough to see what triggered the issue.
A side “problem” I’m having is that I can call mycroft via voice, after which I say a command, but nothing happens. But I wanted to try the gui first to see if it’s me doing something wrong.

I managed to fix the issue:
I went into and found out that the issue is that when installing phonon-qt5-backend you can choose between two backends, and it was defaulting to y for some reason. So, I installed the packages on my own and then removed the installation code so I could run past that.

You must have the aur repositories enabled. The script works without it.

Ohhh, yeah, I do have them enabled

I really think it should really default to pamac when possible. I know everyone else thinks that’s for noobs and heathens, but pamac's apt-like interface makes it much harder to mess up in scripts.

Also it doesn’t matter (edit: to pamac) if the AUR repos are enabled.