Error installing mycroft-configuration Skill

Hey guys,

I just installed MyCroft as a fresh install on Raspbian using the master Git branch, then ran mycroft debug. I can see the microphone volume level changing so it’s clearly been found but I noticed a couple of errors in the debug, and the wakeup command is not working.

Here’s what I see in the logs:

17:40:14.412 - mycroft.skills.skill_manager:install_or_update:232 - WARNING - Failed to install default skill: mycroft-configuration
17:40:14.413 - msm.mycroft_skills_manager - ERROR - Error running install_or_update on mycroft-configuration: PipRequirementsException(
Pip returned code 1:
Requirement already satisfied: requests>=2.13.0 in ./.venv/lib/python3.5/site-packages (2.20.0)
Collecting humanhash3
Using cached
Complete output from command python egg_info:
Traceback (most recent call last):
File “”, line 1, in
File “/tmp/pip-install-1bjmewnj/humanhash3/”, line 7, in
long_description =
File “/usr/lib/python3.5/encodings/”, line 26, in decode
return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: ‘ascii’ codec can’t decode byte 0xe2 in position 1081: ordinal not in range(128)


Command “python egg_info” failed with error code 1 in /tmp/pip-install-1bjmewnj/humanhash3/

also, lower down I see this:

17:40:28.900 - AlarmSkill - ERROR - Couldn’t allocate mixer, ALSAAudioError(‘Unable to find mixer control Master,0 [default]’,)

Have no idea how to get passed this; looks like a bug in the “humanhash3” package itself? Any ideas?

Before anyone asks, I didn’t install PiCroft because I had an existing Pi and it’s running OpenHab on it right now, so I wanted to install Mycroft alongside that.

It could be that you dont have pulseaudio instaled. You could try installing by

sudo apt-get install pulseaudio

I know that helps on Picroft for a lot of issues with audio and missing mixer control.

Hi Ruggero,

Just checking as you started with Raspbian rather than the Picroft image, did you change your sshd_config?
sudo nano /etc/ssh/sshd_config and comment out the line (prefix with ‘#’)

AcceptEnv LANG LC_*

For reference, this is the recipe we use for building Picroft images from Raspbian.

For the audio trouble, best to start at our audio troubleshooting documentation if you haven’t already. Have you tried the mycroft-mic-test?

1 Like

@andlo you were right that PluseAudio was not installed - I installed it, but this didn’t help.

@gez-mycroft thank you - no I didn’t follow the picroft notes - I wish I had seen this first! I tried updating the sshd_config and restarting the ssh service - also logged out and back in for good measure, but no luck - the issue persists. How do I “uninstall” Mycroft so that I can reinstall and follow the picroft image steps this time? Just delete the mycroft-core folder and start following the steps, or is there anything else I need to manually remove from somewhere?

1 Like

Almost, if you want to fully remove Mycroft from a system, there are a couple of other locations:

rm -R ~/yourpath/to/mycroft-core
rm -R /opt/mycroft
rm -R ~/.mycroft

Thanks @gez-mycroft! I’ll remove those locations and try following the instructions for the picroft image.