Devkit set up. Some notable issues

Delayed gratification

I finally got around to getting my kit set up today despite being one of the first people to receive the Mark II kit. It’s very very DIY for the enclosure, because I am not travelling to my usual makerspace due to the pandemic. However, salvaging old packaging material brought back memories of making cardboard models as a child! Though perhaps the Galaksija would be a more apt comparison.

Flashing, and connecting to the WiFi was incredibly simple. Kudos to the team and contributors! I have set Mycroft up on the desktop several times before so this was a mindblowing shortcut.

Needs checksum for image download.

I cannot be sure whether the problems I am encountering are due to corruption, and it is a rather large download comparatively speaking since my connection maxes out here at 1mbps. If the sha256 or related information is included somewhere obvious, and I missed them, I apologize for this note. As far as I can tell though, the download link shown in the official docs doesn’t include it, and no txt file with the checksums in the compressed file either.

Confusing pairing process

For some reason, when I registered the device to my account, the devkit decided to restart the pairing process again and gave me a new number, while the website showed that my device was paired. After deleting and pairing several times until succeeding, I postulate that perhaps the settings aren’t being propagated properly from the site to my device, which led me to want to set up a direct SSH connection to the device instead.

SSH public key not propagated

After the device started running, and answering questions, I tried to login to the device several times using the key-based authentication method. The connection kept being rejected, leading me to conclude the settings were once again not being synced from the backend server. This led me to want to instead add SSH keys manually.

Default passwords not found

I then proceeded to try to do a manual login from attaching a keyboard, and switching to a tty session. Which is when I realised I could not log into the local mycroft container with variations of passwords I found online. While I definitely understand the need to use key-based authentication (I personally only use it when connecting to servers I manage) this would be an instance where a password should be provided.

If it is auto-generated, perhaps it can be dropped into our device info page? Regardless, I found it troubling that I was actually starting to read on how to set up the devkit’s OS from scratch (or overwrite the passwords manually) rather than using the pre-built image because at the very least I would have the root passwords in hand and truly own the device.

Factory reset doesn’t work

I tried it. Let it stew for a few hours. Nope. Still paired and connected after randomly showing the setup screen for a new device briefly before crashing. Could be an issue if one were to for example pass on the devkit to someone else for testing thinking the factory reset option worked as expected.

It turned out to be a silver lining though, as the failed factory reset must have triggered a proper update to the device configuration because I was able to SSH into it shortly after the failed reset.

Shutdown doesn’t work

I chose the turn off button from the GUI interface and waited for far too long before the device rebooted instead of turning off.

Screen and LEDs not turned off by default after reasonable time has passed

I can probably set them up with a bit of tweaking, though by default I would humbly suggest a timer of sorts for the screen and the LED. The wakeword and the Pi’s LED should be adequate indicators for whether the device is on.

My hometown isn’t there

I found it amusing that I was unable to set up my hometown in the web app, and had to choose the state capital instead. Just wanna say it’s perfectly fine to be non-omniscient! There will be places that are not notable enough to be worth mentioning in any database, and it turns out where I live is one of them. And I readily agree!

Concluding thoughts

Overall I am pretty excited to test out using and maybe try my hand at writing some skills for Mycroft. I spent a couple of hours reading up on what I think would be relevant to the issues I discovered and if I missed them, please drop the links here.

I am also unsure where I should be filing my bug reports, so my apologies for dropping the entire chunk here. (Update: I managed to miss the link to the proper github page several times!) If there is suppose to be a main repo somewhere that deals specifically with the use of the daughterboard with a Pi 4 with the default image, I would be happy to use that instead.

Looking forward to working with everyone to make open source AI better, and sustainable!


Hey rewarp - thanks for sharing your experience with your Dev Kit, and glad you got around to getting it setup!

To respond to some of your specific comments:

  • Yes we need to add the hash values for all downloads - I’ve added a ticket for me to add that to our release process.
  • The pairing failing but reporting that it was successful is a concern - @ChrisVeilleux what’s the best way to debug what might be happening here?
  • There is no default password for the Mark II - anywhere online that suggests otherwise is incorrect.
  • Factory reset hasn’t been implemented yet, and we should have removed this from the menu list already. I’ve just done a PR to hide that until the functionality is added.
  • Shutdown we are working on at the moment.
  • timed sleep is also needed and is in the backlog to implement

That link is the best place to report bugs and feature requests specifically for the Mark II.

1 Like

Awesome! Thanks for the response.

I figured out that once I established an SSH connection, and logged out as the mycroft user I had root privileges so I can set my passwords that way.

Will plug away and enjoy the process of building my own baby AI :laughing:

1 Like