Custom Wake word

Hey I am trying to get a custom wake word but when I change the custom word it does not work. Every time I test it, it only response to hey mycroft.

  "hotwords": {
    "your_wakeword": {
        "module": "precise",
        "local_model_file": "~/.local/share/mycroft/precise/models/something.pb"
        "threshold": 1e-90,
        "sensitivity": 0.5,

    "wake up": {
        "module": "pocketsphinx",
        "phonemes": "W EY K . AH P",
        "threshold": 1e-20,
        "lang": "en-us"
  "listener": {
        "wake_word": "your_wakeword",
        "stand_up_word": "wake up",

should do the trick. From how the question is formulated i could imagine you want to running both (your_wakeword and hey mycroft) in tandem. That’s not working.

1 Like

I tried this but it didn’t work. I have every limited coding experience when I made the change I got this output.

parse error: Expected separator between values at line 6, column 19
WARNING: Configuration file does not pass validation, see errors above.
Press X to abandon changes, S to force save, any other key to edit again.

I am not sure what edit to make to fix that.

the file is written in JSON notation
looks like

{ #start
"bla":"bla",  #comma bc following item
"bla": { #value contains another key:value
   "bla": ["bla", "bla2"] #no comma, no following item
    }, #comma bc following item
} #end

the only thing to really look out for (besides key/value (data) types) are commas in the hirarchy. This example (although a bad one due to the comments - dont do that) may guide you

Awesome, that worked but now it reacts to any sound. I am going to stop working on this for tonight. Thanks for the help.

That is most likely a model (training and/or sensitivity/threshold) issue

Yeah not enough data (particularly not-wake-word data) seems to be pretty common.

Yeah so I was able to get it to stop waking up to any sound but it is still only reacting to hey mycroft. I am really confused why.

would you please post your (relevant parts) of the config? If you point to another (precise) model, there is no way mycroft is able to load “hey mycroft”. Also be sure there are no double mentions (system/user conf; user overrides system). And maybe the output of voice.log. (using