Conflicts when installing mycroft-core

Cloning the core repo and then run the bash script while selecting a local build/install, I get this far before it stops. What is the recommendation path forward. Note that geary is actually instead, so not sure why that is a recommendation.

We have detected that your computer has the libjack-jackd2-0 package installed.
Mycroft requires a conflicting package, and will likely uninstall this package.
On some systems, this can cause other programs to be marked for removal.
Please review the following package changes carefully.
Press enter to continue
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
autoconf is already the newest version (2.71-2).
autoconf set to manually installed.
automake is already the newest version (1:1.16.5-1.3).
automake set to manually installed.
build-essential is already the newest version (12.9ubuntu3).
build-essential set to manually installed.
jq is already the newest version (1.6-2.1ubuntu3).
jq set to manually installed.
libffi-dev is already the newest version (3.4.2-4).
libffi-dev set to manually installed.
libglib2.0-dev is already the newest version (2.72.1-1).
libglib2.0-dev set to manually installed.
libicu-dev is already the newest version (70.1-2).
libicu-dev set to manually installed.
libjpeg-dev is already the newest version (8c-2ubuntu10).
libjpeg-dev set to manually installed.
libtool is already the newest version (2.4.6-15build2).
libtool set to manually installed.
pkg-config is already the newest version (0.29.2-1ubuntu3).
pkg-config set to manually installed.
pulseaudio-utils is already the newest version (1:15.99.1+dfsg1-1ubuntu1).
pulseaudio-utils set to manually installed.
python3 is already the newest version (3.10.4-0ubuntu2).
python3 set to manually installed.
python3-dev is already the newest version (3.10.4-0ubuntu2).
python3-setuptools is already the newest version (59.6.0-1.2).
python3-setuptools set to manually installed.
curl is already the newest version (7.81.0-1ubuntu1.2).
curl set to manually installed.
git is already the newest version (1:2.34.1-1ubuntu1.2).
git set to manually installed.
libssl-dev is already the newest version (3.0.2-0ubuntu1.1).
libssl-dev set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pop-desktop : Conflicts: pulseaudio
Conflicts: pulseaudio:i386
Recommends: geary but it is not going to be installed
Recommends: io.elementary.sideload but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Hey Szul, welcome to the forums.

What distro are you running? Pop OS? or Elementary?
Just trying to guess based off those package names…

One of the things we are working toward is removing all these dependencies so that Mycroft is more portable across systems. In the short term, I wouldn’t want to make any suggestions without a deeper understanding of your system.

1 Like

That would have been helpful. See neofetch below. Pop OS 22.04.


First a warning - I haven’t tested this and I’m assuming anyone reading this is familiar with basic package management in Linux.

My understanding is that Pop uses pipewire, so you can probably just drop the pulseaudio packages from the install list, eg:

sudo apt install git python3 python3-dev python3-setuptools libtool \
        libffi-dev libssl-dev autoconf automake bison swig libglib2.0-dev \
        portaudio19-dev mpg123 screen flac curl libicu-dev pkg-config \
        libjpeg-dev libfann-dev build-essential jq

Just check that this isn’t going to replace any packages.

Then comment out or delete line 512 from


so it doesn’t try to do it’s own package installation.

Let us know how it goes

A post was split to a new topic: Installing Picroft - Raspberry Pi board requires newer software