Configuring Emby server

Hi Mycroft
I am having trouble getting emby to stream music through mycroft. I have the server running and I can play music over a wifi network on my laptop, but not mycroft. Can someone please tell me how to configure mycroft…what the url should be and how to tell him to play music.

I had some connection issues as well when I first configured Emby. When I copied the local host address on the Emby dashboard I also included the port number. (192.168.x.x:8096). When I took out the :8096 it worked. I try and look at these forums often so if you have more questions, I should be able to respond quickly. Good luck. :smile:

1 Like

Thanks for reply I have corrected a mistake in url, but it still does not play me music. Can you tell me how to ask mycroft to play something. I have individual folders for each artist. some contain album names. Do I ask for the artist (folder name) or the album or the name of a track. (probaly a silly question but hey)
Thanks again

Try saying Hey Mycroft… Play (group name) from Emby.
Make sure Emby is up and running before you say anything.

You should be able to ask for a specific song, band, album etc. However Mycroft does not always recognize when I get more specific.

Also, what type of error are you getting? Unable to play? or unable to connect to Emby? Or something else? :smile:

@sampsonight Is the author of this skill. He may be able to help with this.

To see which skill is returning the highest confidence level you can run:
cat /var/log/mycroft/skills.log | sed -n -e 's/^.*Playback Control Skill - DEBUG - //p'
You can also just grep the file, but this gives a cleaner output.

Remove the "DEBUG - " if you want to see more detail by including the INFO log messages.


You should be able to ask Mycroft to play music in the following format:

"Play {Artist/Song/Album} From Emby"
"Play Artist {Artist} From Emby"
"play Album {Album} From Emby"

Where anything in the {} is filled in by an artist/song/album in you’re collection.

As others have mentioned please provide the error you receiving and the logs :slight_smile:


How specific are you getting? I can add additional phrases to get very specific, even down to artist -> album -> song, but was not sure exactly how to add a phrase so it still sounds natural vs prefacing each variable with the expected type E.g Artist {artist}

Hi All and thanks
But Emby still does not wotk
my URL is; http://192.168.*.**
my port is; 8096
username is; aaron
password is blank

I say; Hey Mycroft, play blue by emby (blue is the name of a folder/album)
Mycroft responds ‘I cannot play blue’
Sometimes he does not respond at all.

What am I to do?
Thanks again

Hey Aaron, there are two simple ways to get your logs.

If you want all of them you can say “create a support ticket”. Mycroft will thenupload all of your logs to and email you a link.

Alternatively if you just want the skills.log you can SSH in and run:
cat /var/log/mycroft/skills.log | nc 9999

This should give a better understanding of what’s happening under the hood. We want to check whether the Emby Skill is actually getting triggered, and what other errors might be present.

Well i tried “Hey mycroft create a support ticket” he responded and I said yes, but I got no email.
I tried “ssh pi@192.**..166”, but i get “port 22: No route to host”
Sorry guys. I’m not very good at this.


You shouldn’t have to be good at anything to create a support ticket, so not sure what’s happening there.

Are you using a valid email address on
Is there any chance the email got flagged as spam?

What type of device are you running?
If it’s a Mark 1 you need to first enable SSH access by holding down the button on top, selecting SSH and then changing that to ‘allow’.

Hi again
Okay. I am on a picroft. It seems to work when I ask what time it is and other stuff. I have managed to ssh into it and this is what I am getting:-

protobuf-3.6.1-cp35-cp35m-linux_armv6l.whl is not a supported wheel on this platform.
dpkg: error processing package aiy-python-wheels (–configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
Starting cli
(.venv) pi@picroft:~ $

Any suggestions?

Hey, I’m guessing you are using the AIY Kit?

The protobuf wheel seems to be a constant problem but if Mycroft is responding then it should be ok.

After SSH’ing in you now have a command prompt in the virtual environment (aka venv). So here is where you can enter the command:
cat /var/log/mycroft/skills.log | nc 9999

This reads the skills.log file and sends it to The terminal should return a url that has your log file. If you post that url here we can take a look at what might be happening to Emby.

I think I done it. here is the URL


Looking at the logs I don’t see mycroft making any attempt to load the Emby skill. There also appears to be other errors loading skills, though I can’t speak to why those are happening.

How did you install/configure the emby skill?

I added the skill on the mycroft ai skill marketplace? page, and then configured the path to the emby server on the first mycroft ai skills page.

That all sounds right. I’m going to defer to @gez-mycroft about the logs. There are defiantly some errors that may be contributing to emby not being installed, but can’t say for certain.

Yeah it definitely does not seem to have installed. I will have a chat to some others in the team to see what might be happening from the backend side of things.

If you say “Hey Mycroft, install emby” that should trigger it to download and fetch the settings.

Also just worth mentioning that given your using the AIY Kit it’s probably a good idea to stay on 18.08 for the moment as we are trying to resolve an issue with audio getting cut off on longer responses.

I did ‘Hey Mycroft, install emby’, and he told me ‘emby was already installed’.
I have just tried to uninstall emby via Mycroft home and although I seem to be logged in I cannot activate or deactivate any skills. The page seems to be stuck on ‘loading your skills…’