Check out Mimic TTS!

It’s official, Mimic TTS, a fork of Carnegie Mellon University’s FLITE software, has been released. You can check it out at

And here is the awesome video:


Has anyone gotten Mimic running on OS X?

Says it’s supported, but when I ran the configure, it didn’t seem like it found any audio devices, and when I built it, everything runs but there is no audio.

I’m on a Macbook Air OS X 10.11.3.

1 Like

I’m running Ubuntu 15.10 and had the “oss_audio: failed to open audio device /dev/dsp” issue which is filed here and @forslund helped me out on IRC (#mycroft on freenode).

It came down to a missing dependency: you need to get “libasound2-dev”. After installing that, you need to do “make clean”, “./configure” and “make”.

Then ./bin/mimic "Helo wurld" should work.

Unfortunately @Tev, @forslund tells me that this might not work for OS X users, as libasound is for the Linux Alsa driver. Still, figured this info might help somebody experiencing similar issues.

@ryanleesipes - can you guys elaborate a little on what advantages mimic brings over other linux talkification programs like espeak or default festival/festival-lite please? Also, can you tell us a little more about the vocalid partnership? Thanks

If you can’t use your audio device, you still can redirect output to a wav file.

@Autonomouse yes, Mimic is a fork of Festival Lite (FLITE) with very little added on top at the moment. We forked this as a result of what seemed to be a lack of interest from the maintainers (Dr. Black and CMU) for supporting the software and participating in its development at the level we were interested in. To elaborate we wanted a public repo and a dedicated maintainer who would review pull requests and actively participate in the development process.

We are working with VocaliD in order to create an original set of creative commons voices that will be available for public use. We are still brainstorming with them how we can best bring custom voice creation to the community through their service. They are using Mimic now as the recommended software to synthesize their voices, and hopefully our work on Mimic will improve the lives of those who rely on VocaliD for speaking.

1 Like

I would gladly go through the VocalID donation process to record my voice if at the end I also got a copy of the files for my own use. That seems fair…

Good tip! I can do this to play around with it on OSX:
./bin/mimic -t "Test phrase." -o "output.wav"; afplay output.wav

I imagine that the solution here is to figure out the equivalent to libasound2-dev on OSX?

Since each request to speak something starts the Mimic program over again, is there any latency hit compared to using full Festival in its server mode, commanding it over a network connection?

I only have anecdotal evidence to back me up @pdtwonotes but it seems faster to have Mimic spin up and actually synthesize the voice on the client-side than wait for the server. Even when I’m sitting on a really good network, and even using the Pi for synthesis (client-side).

This is, of course, anecdotal. Testing + data collection is the only real way to know.

Unable to make it work under Arch Linux.
mimic -t "Hello. Doctor. Name. Continue. Yesterday. Tomorrow." oss_audio: failed to open audio device /dev/dsp
No libasound on arch linux, but
alsa-lib 1.1.0-1 [installed] OSS compatibility library A heavily multi-threaded PCM player that tries to excercise the ALSA library and driver quite a bit

Any idea?

You could try wrapping the command in padsp to get rid of that error for the time being. (padsp ./bin/mimic -t "Hello") (sorry, I don’t know if arch has padsp or not)

I am also on Arch it for me commit 8e28e5b works as it should. I don’t know if it matters but in the pkgbuild you could chose between pulseaudio and alsa. I edit it to use pulseaudio as that is what I use. I am using a tiling wm so neither Gnome nor Plasma.

Else the output of ‘strace -eopen mimic -t TEXT’ and/or ‘strace mimic -t TEXT’ could probably help.

The speech coming out of mimic is a monotone. Even with obvious pitch markers like a question mark at the end results in no pitch inflection. I have tried over half a dozen different voices, so I don’t think it is there.

Is there a notation that can be put into the text strings that will force pitch inflections?

I am on Ubuntu 16.04 and so far using padsp before ./bin/mimic has been the only way I’ve been able to get it to work. But I am no expert on audio drivers or TTS.

Do you have libasound2-dev installed?

Yes, if I try to apt install I get:
libasound2-dev is already the newest version (1.1.0-0ubuntu1).

Just entering ./bin/mimic -t “Hello” produces the error mentioned above:
oss_audio: failed to open audio device /dev/dsp

hmm… strange, I haven’t updated to 16.04 yet, but I will look into this as soon as I do. Is yours a fresh install or have you updated from a previous version? (I don’t know if it makes a difference, but it doesn’t hurt to know)

It was a fresh install.

The version that comes with the new mycroft-core release now has this working on my system without padsp.

Hey guys. I would like to point to firefox addon which sounds like a real human to me. Maybe you could try to contact the author for some kind of cooperation