Cant open cli in picroft 0.9

After flashing the SD card with the image v0.9, Mycroft seems to be crashing.
When trying to enter the console I get:

pi@picroft:/etc/mycroft $ mycroft-cli-client
20:49:27.058 - root - INFO - Generating grammar tables from /usr/lib/python2.7/lib2to3/Grammar.txt
20:49:27.201 - root - INFO - Generating grammar tables from /usr/lib/python2.7/lib2to3/PatternGrammar.txt

And after that it just goes back to

pi@picroft:/etc/mycroft $

@forslund - any ideas here?

This could be a case of missing/incorrect python packages.

Things to do to debug the issue:

Check the log-files:

/var/log/mycroft-speech-client.log and /var/log/mycroft-skills.log and post them on something like If really bad stuff happens the log should be short and basically consist of python stack-traces.

run the command ps aux | grep mycroft (this will list the running Mycroft processes), this should ideally show at least:


You could also try to do an update. The latest version of the CLI is much better at reporting issues.

sudo apt-get update && sudo apt-get install mycroft-picroft (if memory serves me correct)

Let me know what this yields and I’ll try to continue debugging the issue. I’ll also ping @Mn0491 who has a lot of picroft experience.


Here are the logs, seems like an alsa problem:



I updated everything, and the situation is still the same. But looking into other posts I discovered y haven’t virtual env installed. Could this be the problem? Please I’m trying to include Mycroft in my grade project but the last three days have been totally frustrating.

Hold tight, we’re tracking a recent problem with Picroft and microphone, that has been present since last Thursday. More updates as they come to hand.

Ok, glad to hear I’m not the only one but sad this happened, please give me any task you are able so i can contribute to this fix, I’m more than interested in having this working as soon as possible.

Thanks for the feed back. That is very good information.

It looks like the messagebus service is either not starting or crashing. Can you post var/log/mycroft-messagebus.log as well.

Oh damn! I just flashed the card to try to make v0.8 work :frowning: sorry

No worries, if it works better you should use it!

I’m sorry to say it, but it doesn’t

same problem here. I installed Mycroft on Raspbian using your Repo but I get exactly the same issue.

Hi there,
it could be just a permission issue to the soundcard, could you try to execute

sudo useradd -G sound mycroft

after that run


and set the soundcard volume.

Hope it helps

I’m in Picroft v0.8 now and when I try to add mycroft user to sound it returns

useradd: group 'sound' does not exist

just shooting in the dark but looking at some services I found that many of them has symbolic links to /dev/null, can that be part or at least point to the problem of messagebus not starting/crashing?

HI ibabicuy could you try with group audio

sudo useradd -G audio mycroft
sudo usermod -g audio mycroft

it returned
useradd: user 'mycroft' already exists
So it seems that wasn’t it, thanks anyway for the advice and any idea will be thankfully received!

In that case use

sudo usermod -g audio mycroft

If you use on standard Raspbian make sure you set it to use aplay instead of paplay for wav playback. See

well I seem to have found the problem
when run ./ i found that cli is not in the repo under /home/pi/bin

Thanks for all your investigations here, I’m going to flag this with @forslund just so he’s aware.