Can't install wireless drivers on Picroft or get audio

I just imaged my RPi with Picroft and it boots and runs through a bunch of stuff.

Now I’m trying to install drivers for my TPLink wifi adapter (T4U).

I downloaded the drivers from their website, but when I run a make on them, I get the error:

     make[1]: *** /lib/modules/4.4.21+/build: No such file or directory. Stop.

So, why am I asking about a 3rd party driver on this forum?

Because I also tried an open source driver for the adapter and got the same error. So I tried getting a little deeper by manually creating an empty “build” folder, and the installs proceed one step farther, getting this error:

     make[1]: Entering directory '/lib/modules/4.4.21+/build'
     make[1]: *** No rule to make target 'modules'. Stop.

I have some linux experience from the admin side, but I’ve never compiled anything on it. It feels like maybe there’s something in the Picroft build that is missing, which these supposedly simple driver builds aren’t able to find. But I don’t really know…

I did some googling and came across some proposed fixes, but none of them work, always indicating something isn’t set up correctly with the file structure maybe?

This is in addition to the problem I have where Mycroft doesn’t speak to me, I never get a pairing code, and the audio log indicates some strange errors.

Does it sound like my build is jacked or am I just missing something?

OK, I think we’re dealing with two separate problems here - one is the TPLink WiFi adapter issue, and the second is Mycroft not responding.

The WiFi adapter issue is not one we’ve observed frequently. Can I ask why you need to install the WiFi adapter? Is it because Picroft is not connecting to your WiFi SSID?

The second issue, with Mycroft not responding, has a couple of workarounds.

  • sudo service mycroft-skills stop && sudo service mycroft-skills start

This stops and starts the Skills service, which we think has been preventing the Pairing Skill from running.

  • sudo apt-get update && sudo apt-get upgrade

This does a manual update.

Please let me know how you go.

Hi Kathy,

The WiFi adapter doesn’t seem to be working - Picroft starts the WiFi setup process then complains “failed to fetch remote configuration”, “failed to establish a new connection (name or service now known)”, throws some line numbers out, then just keeps retrying the connection.

I don’t know if it should be prompting me for SSID or other config info, but it never does. So I thought maybe I needed to manually install the driver.

I’ll try the service restart tonight after work with it hard wired - luckily I figured out how to share my PC’s WiFi connection via ethernet so at least I can get PiCroft online for the initial setup.

That’s helpful information @Philomorph thank you.

This doesn’t sound like a WiFi driver issue, it sounds like it’s not starting properly.

Definitely let us know how you go with the service restart,

Kind regards, Kathy

I fooled around a fair amount with this and finally got tired of it, thinking I’d possibly messed it up with my attempted driver install.

So I started fresh - re-imaged from scratch.

Plugged into Ethernet - no wifi. Booted up, let it do its thing. Ran manual update and upgrade commands as instructed, rebooted, let it do its thing - again it said “Register using the code below” but no code is shown.

Tried service stop/start, but not sure what to do next… sitting at command prompt - have no code for registration.

OK, this may be a hangover from an outage we’ve been experiencing over the last couple of days - apologies for the inconvenience.

Can you try rebooting the Picroft and seeing how you go?

Again, our apologies for the frustration.

Kind regards,

Thanks Kathy!

I rebooted and this time it got to “starting up services” and said “Internet connection not detected, starting WiFi setup process”, which I’ve seen before, even though it should have internet through my main PC’s ICS. Then it started mycroft.wifi.start and told me to connect to the mycroft network (which of course doesn’t exist with no wifi adapter plugged in).

It just hangs there forever.

So, I tried plugging in the wifi adapter and rebooting - mycroft eventually talks and says

“There was a problem starting my wifi hardware - please try rebooting”

So I tried a different wifi dongle - this time an old generic one - same result

So I tried another one (I have many) - this time one I know has worked with this rPi before when it was an Octoprint server.

There were many new messages on boot up that I’d never seen, stuff about ifup on the wifi, some failure messages that flashed by, etc.

But in the end - same result. No “mycroft” AP ever appears and the voice tells me to reboot.

But hey, there’s a voice now!

OK that’s helpful information, @Philomorph.
Can I ask what model Raspberry Pi you are using?
Why does it need a WiFi adapter? The RPi 3, which we recommend, has on-board WiFi.

Ahh, well I guess I jumped in feet first to Picroft - I have an rPi B+ (rev 1.2). It does not have WiFi built-in.

But the last of the dongles I tried has always worked with Raspbian, no driver install was necessary when I’ve used the Pi for other things. I suspect that’s why it was giving me more related messages on boot with it plugged in, as opposed to the other two units.

So, unfortunately Mycroft requires a Pi3; the earlier Pi models just don’t have enough CPU or memory I’m afraid :frowning: