Can't install or configure skills from marketplace

** Picroft enclosure platform version: Stretch Lighting
** mycroft-core: 19.2.14 ( master )
Using the Google AI voice kit

I swear this worked before, but doesn’t work any more. I reinstalled Mycroft on a Pi yesterday, deleted the old device from my account, added the new device. It’s paired successfully with my account. I go into the skills marketplace, select a skill, and click “Add”. Nothing happens. The button has the graphical effect showing that I clicked it, but that’s it. Nothing is installed on the device, marketplace doesn’t show it’s installed or doing anything, and nothing shows up in the “Configure Your Skills” page. Rebooting the device doesn’t change anything. I’m almost confident I installed and configured skills through the web UI on the previous device, (which was really the same hardware, I just did a fresh install).

I can install skills manually on the device using MSM or cloning skills directly, but none of those skills show up on the web dashboard as installed or configurable. Changing voices from the web UI changes the voice on the device, so there is definitely communication between the device and the web. Any ideas? Is any of this expected behavior, or is all of this unusual?

This is a known bug that is being worked on. Check the chat ~home-troubleshooting for updates (though there will likely be a post here as well).

1 Like

Looks like the skills page is down again.

I am having a very simular issue.
Installed a test device some months back. Installed PiCroft on a new Pi4 last Saturday and paired it succesfully to my account. Installed some skills that also were on my test device. The skills showed up at first on the ‘Configure your skills’ page (some skills got an additional ‘Version 2’ tab page where the new Pi4 was listed). So far so good.
I then deleted my old test device from my account.
This resulted in ALL skills begin removed from the ‘Configure your skills’ page.
I already tried removing the new device from my account and adding it again but that had no effect.
Is there anything I can do to fix this? Or should I maybe delete my account and create new one?

I have exactly the same issue.
Can’t use Mycroft anymore. Nothing can be controlled. Lights or smth. else. :frowning:

i have the same problem, can’t use any skills in mycroft anymore…

1 Like

It looks like there are three separate problems going on here.

Those of you who can’t install skills from the marketplace, that’s a known thing. The marketplace is effectively down at the moment. You can, however, install and uninstall skills by voice: “Hey, Mycroft, install Emby” should ask you to confirm that you want to install the Emby skills, and then do so.

If you can’t configure skills from the dashboard, that’s out of my realm of expertise.

If you can’t use skills on your Mycroft device, something is probably wrong at your end, and you’ll wanna make another thread, or seek help in chat. Could be a borked update. If you mess with it in the CLI, could be a bum change. Could be a number of things.