Can't find .mycroft

I’ve been trying for several hours to install mycroft on my 2019 Intel chip MacBook Pro.
I set up Docker and pulled the mycroft/docker-mycroft image. Im not great at line commands but with some help with ChatGPT to help with the gaps I did get everything installed as far as I can tell. However, It keeps saying it doesn’t find .mycroft anywhere. I have looked, made sure to look for hidden files. Can anyone help> Im really excited to get the running. THANKS,

Here’s what I’ve done so far:

  1. I’ve successfully pulled the Mycroft Docker image using the following command:

bashCopy code

docker pull mycroftai/docker-mycroft:latest
  1. I’ve searched through my home directory (/Users/nothing) and its subdirectories using the find command, looking for the .mycroft directory. However, I’m encountering “Operation not permitted” errors for some directories, likely due to macOS’s permissions settings.
  2. I’ve checked my home directory and other subdirectories manually to locate the .mycroft directory, but I haven’t been successful.
  3. I’ve reviewed the official Mycroft documentation, but it’s primarily focused on Linux setups, and I couldn’t find specific guidance for Docker on macOS.

I’d greatly appreciate your assistance in locating the .mycroft directory or providing guidance on where the configuration and data files might be stored within Docker containers on macOS.

Any help or advice you could provide would be incredibly valuable. If you need more information about my setup or any specific commands I’ve tried, please let me know.

Thank you in advance for your support!

Best regards, [Your Name]

Forgot to edit the last part of that chat gpt response, Mycroft is no longer maintained, read the faq, you likely want to try OVOs or Neon. If chatgpt wants to know the answer it can ask the question itself, please put some effort as a human in your support requests, would you like it if the support you got back was also chatgpt generated instead of meaningful?


Thanks for the direction. Would appreciate it if maybe you would consider that I know next to no coding like this and I put in a ton of effort myself for many hours up until I couldn’t figure it out anymore. Your assumption about it being all chatGPT is, to put it nicely, inaccurate.

I know when someone else knows less than me I tend to be mindful that we are all better at some things than others rather than criticize them. I’d rather treat others the way I’d like to be treated and ask questions rather than make mean spirited assumptions and comments to a newbie trying to get something to work.

Just saying.

#CommunityGuidelines #BeKindToOthers #DifferentSkills

1 Like

The fastest way to get up and running on Mac today is probably this: GitHub - OpenVoiceOS/ovos-docker: Open Voice OS container images and docker-compose.yml files for x86_64 and aarch64 CPU architectures.

Mycroft is effectively unmaintained and I don’t think it ever had Mac support, but I could be mistaken about that.


You are correct. A few of us tried over the years - mostly me - but until Goldy announced he had OVOS-Docker running on Mac, the best I had personally achieved was thin client support (which ain’t peanuts, but it ain’t the goal.)

OVOS-Docker is definitely the best bet.

1 Like

OVOS will work as well on Mac OS even without Docker.

The main blocker was related to ALSA which only work on Linux. In order to fix that, we developed a microphone plugin using sound-device Python library which allows us to get a cross-platform plugin.


Does it load past that now? You can install alsa with a package manager, but that was nowhere near the bottom of the rabbit hole in the old days.