Api Connection problems + Pywheel not installing + more

Hi everyone, I currently have a raspberry pi 4B running Rasbian buster

I cloned the mycroft-core git repo, ran the installation, chose stable and installed mimic locally using the install script.

Pip always complains that it cannot install pywheel in the venv that mycroft is in, and most of the time it is timing out on connections to api.mycroft.ai

Additionally, running ./start-mycroft.sh debug, after a restart, running the script for the first time, the microphone is not used. if I type :exit or press CTRL+C, and run it again it works.

If I close the script and open it several times, it bugs out and does not load the skills. It loads the precise engine wake word, but nothing else. If I speak to it, it either does not respond or tells me please wait as I boot up and never finishes unless I reboot.

What’s going on here?

That seems problematic. Any idea why?

None. I checked my connection, it was working fine.

It’s a weird timing issue using Raspian vs. Rasp Pi OS. I don’t know why. Put a pause/wait for 10 seconds in the startup. I don’t remember exactly how many steps in, I think it was just after the first call.
Find this in “start-mycroft.sh” and insert the sleep 10 line:
function launch-all() {
echo “Starting all mycroft-core services”
launch-background bus
launch-background skills
sleep 10
launch-background audio
launch-background voice
launch-background enclosure
then do a “./stop-mycroft.sh”
then do “./start-mycroft.sh all”
or, try restarting your Pi to test it and see if it works properly on reboot as well.
Hopefully that takes care of it for you. If not, I don’t know what else it would be. That’s what worked for me, but I just updated my OS and don’t have the problem at this time.
All I did was start putting a sleep in between states one increment at a time until it worked. That’s where it happened to work for me. Good luck!
Take care

Hi Mandrake, thanks for the reply. I tried this and it did indeed help. Also, according to what I learned, if I want to restart mycroft, I should use:

./start-mycroft.sh debug restart

Also helped me with the weird behavior.

Awesome! So glad it helped out. Also glad you found the one-liner for restart.

Have a great weekend :slight_smile:

1 Like