Anyone using ReSpeaker 6-Mic HAT in Picroft?

I’m mainly wondering if the instructions on their site ( are the ones to follow, and how to use librespeaker in conjunction with Mycroft (if needed). Thanks!

Well, I may be returning this product depending on how this nets out. The driver repo ( does not compile with the latest kernel. And the “solution” to the issue they propose is to use a fork that downgrades the kernel to one that is nearly a year old. I’m not sure this is a product I’d like to continue using considering the premium paid for a product that should be plug and play, but I’m waiting for an official response from support.

Haven’t tried that one sorry, sounds like a rough suggested work around too… hope they come back with something more useful

Hey @Fmstrat,

I just setup Mycroft on my Pi4 with the ReSpeaker 6 mic array and it is working. It took me a few hours of debugging the Audio Input and Output setup, but it seems to working well now!

I found this repo rather helpful:

My initial attempt to setup the ReSpeaker failed because of some kernel incompatibility errors, but i rebooted and ran sudo ./ 6mic and that worked while the first time I did not include the 6mic at the end as it does not say this in the Seeed documentation.

I did not mess with the ~/.asound.rc as reccomended in this repo though. Once I setup the hat, I just went into the Mycroft audio setup and started debugging issues based on their audo troubleshooting section

I am planning to hook into some the mycroft message bus to trigger the light array that comes with the Respeaker6Mic. I hope you found some success with your 6Mic, and I am happy to share any more info that might help!

1 Like

i’ve installed the hat but i do not understand what i need to do for make it works

are you getting errors, what have you tried, what do you see when you type arecord -l and / or aplay -l

seeed respeakers have trouble with newer kernels, what kernel do you have, uname -l to find out. You might have to install with compatible kernel, --compat-kernel when you run the respeaker install.

don’t know how but now it’s working