Adapt intent builder issue

This issue I’m having is strange to me and shouldn’t be happening (it’s also probably a very simple fix!)

I began by creating a fresh project, cloning “00_skill_template” on Github to my own Skills directory (I’m on Ubuntu).
I removed the default “Hello World” skill from my skills directory so I wouldn’t have utterance conflicts (“00_skill_template” is initally triggered by Hello World too).
I verified that the template skill was being triggered by the “Hello World” utterance by having it output “This is template skill speaking”.
Wanting to trigger my skill by something other than “Hello World”, I modifed the decorator from:

to become:

Noticing that each “.require(“x”)” word has a corresponding “word.voc” file located in “00_skill_template/vocab/en-us”, I created “Data.voc” there (Could someone enlighten me on these .voc files? All I know is that they’re audio files [which I couldn’t even open]. Do I record myself saying “Data” here?) .
With this all in place, I save my “” file, I see Mycroft CLI update the skill with my changes.
I attempt to run the same skill with keyword “Data” now instead of “Hello World”, then Mycroft replies “I don’t understand”.
Not knowing how/why this is happening, I do the following: update Mycroft configuration, restart Mycroft Skills, restart Mycroft, restart, my computer, but nothing is fixing it.
I attempt to use the “intent_file_handler” decorator instead, with a “*.intent” file as it’s parameter, but still to no avail.
I attempt to create a new handler with a new decorator (leaving the “Hello World” one intact), but absolutely no other intent handler + decorator pairs are being registered with Mycroft.

What could I being doing wrong here?
I’m very much a beginner with Mycroft and I greatly appreciate anyone’s help in enabling me to jump these initial hurdles!

Thank you

They’re not audio files they’re just text files with keywords for, in your case, data

So Data should contain something like


See the hello world skill for an example:

I also recommend the excellent documentation put together by @gez-mycroft :

1 Like

Got it. Simply adding entries to the .voc files fixed everything.
I knew it’d be something simple!! :joy: