Accessing mycroft.conf file

Hello - I’m very new to both mycroft and the Linux command line terminal. I’m trying to change the wake word using PocketSphinx phonemes. I have a super n00b question: how/where do I edit the mycroft.conf file? Plz begin with the assumption that I’ve just begun playing with command line yesterday (I did). Should Mycroft be running in my ubuntu VM while I’m editing the code or am I editing code in a separate Python terminal orrrr? I’ve tried typing each of these into the Ubuntu terminal to no avail:


I get either Permission denied or “command not found”

Please go easy! I’m probably missing some hugely basic piece of information re: where I’m supposed to be editing the code from. If you could go real slow I’d appreciate it.

Welcome to the comunity and to mycroft, linux and all the fun stuff :slight_smile:

You are on the right path, but you are right you need some basi knoledeges that the mycroft doc’s presume the reader has.

You have to (well you have other options to) be in a terminal in your ubuntu VM to edit files.

here is an introdusing to the linux terminal

On most linux systems the user is just a user, and has restricted privileges. To give more privileges start the command with sudo. To edit a file use an editor like nano.

So to edit a mycroft.conf you could write nano folowed by the filename (or path and filename) like this

nano mycroft.conf


sudo nano ~/,mycroft/mycroft.conf


1 Like

Hey I just notised an easy way to edit mycroft.conf files :slight_smile: in your teminal run the command

mycroft-config edit system

will open the system mycroft.cond file in the nanp editor :slight_smile:



to se what else you can do with that

if your terminal cant find mycroft-config then navigate to your home directory in the folder mycroft-core in the folder bin
or write this



~/mycroft-core/bin/mycroft-config edit system

notise the tilde at the begining it is a shortage for your homefolder.


Thanks so much Andreas - very helpful :slight_smile:

1 Like

Hi! I tried and had no success running th mycroft-config edit system. Running the latest version on my Mark 1. SSH enabled and I can sudo nano my mycroft.conf file just fine. However, to avoid any errors trying to add the Openhab skill i cannot use the configuration manager.

Do you just putty into your Mark 1 and after logging in just type the command?


yah you can ssh to your mark_1 and type commands in the shell.

I think that to install openhab skill you could type

mycroft-msm install
1 Like