500 server error when installing Spotify skill from Marketplace

When trying to install the Spotify skill from the Marketplace, I get a 500 response from the server.
I’m able to install the skill by asking Mycroft to install it.
However, I still need to register my account with the skill to be able to use it, and I can’t do that from home.mycroft.ai because the skill doesn’t appear in the list there.
Has this issue been seen yet, and is there a fix?

Hi boardfish, thanks for reporting this!

The team discovered and fixed a bug with the skills setting endpoint over the weekend. This was causing problems with the skill settings page for some accounts and could cause units to be non-responsive.

Can you confirm whether you can install and authenticate with Spotify now?

Just had the same error in console when trying to install “Spotify” via the marketplace (Chrome as well as FireFox)

<title>500 Internal Server Error</title>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.</p>

(console meaning: The output from the browser’s devtools, NOT the Linux console)

In case this might help:
I can install the skill on the shell using mycroft-msm where it gets installed without issues but it does not appear in my skills list on mycroft.ai

Hey, we’re working on a separate bug that’s causing the 500 error on the “add” button in the Marketplace. So that will be addressed shortly.

We released Mycroft-core 19.2.13 about 16 hours ago, do you know if your device had updated before testing this? The update included some updates to how we handle skill settings and it seems to have resolved issues that other users were seeing, so I’m hoping that it will be the same here.

If you chose to have automatic updates then this should already be running on your device. Either way, you can say “check version” to tell what you are running and if an update is available, Mycroft will ask if you want to download and apply it.

Hey, I’m running into this same issue, and I’m wondering if it as been resolved and there’s something I need to do, or if there is a workaround I can use. In my case, I’m trying to setup Pandora on my account, though I am unable to add that skill as well as others.

Hi @lwaite2010

The easiest way to install Skills is by voice - “Hey Mycroft, install skill name”

or if you prefer to use the command line you can use the Mycroft Skill Manager:
mycroft-msm install skill-name

Currently the “add” button in the Marketplace is still broken as we made the tough call to put a freeze on non-essential work that isn’t directly related to shipping the Mark II. This will certainly be one of the first items to address when the team return to backend updates.

Hi @gez-mycroft,

I’m still new to Mycroft. I’m using a Mycroft I. I tried to install the Spotify skill and then Mycroft returned that it’s successful. However, when I checked the dashboard, the skill is not installed and there is nothing to configure as well.

When I try to test the commands available for the Spotify skill, I get an error regarding some playbac feature (I forgot what it exactly said).

I haven’t tried accessing the device via SSH though. Am I missing something?

Thanks in advance. I’m actually just looking for a simple tutorial or documentation that I can use in order to navigate the device.

Hi Bluefish,

What sort of device are you using? A Mark 1, Picroft, or a Linux machine?

How did you install the Skill on your device, was this by voice?

We have instructions for the different device types in our documentation, but it would depend on what you are using.