3.5mm Audio stopped working after installing seeed respeaker driver

I am having an issue with mycroft, combined with the seeed respeaker 4mic array on my pi. I performed the following steps:

  1. Installed Mycroft, selecting 4, or “other microphone” for the input, and the 3.5mm for the output.
  2. Tested that the mycroft sound output worked by typing prompts into the mycroft command line
  3. Installed the seeedr respeaker driver from here: https://github.com/respeaker/seeed-voicecard
  4. Rebooted.

After the final step, the microphone was working properly, but the speaker had stopped working.

pactl info output:

Server String: /run/user/1000/pulse/native
Library Protocol Version: 32
Server Protocol Version: 32
Is Local: yes
Client Index: 77
Tile Size: 65496
User Name: pi
Host Name: picroft
Server Name: pulseaudio
Server Version: 12.2
Default Sample Specification: s16le 2ch 44100Hz
Default Channel Map: front-left,front-right
Default Sink: alsa_output.platform-soc_audio.analog-mono
Default Source: alsa_input.platform-soc_sound.multichannel-input
Cookie: d005:a521

pactl list sinks short output

0       alsa_output.platform-soc_audio.analog-mono      module-alsa-card.c     s16le 1ch 44100Hz        SUSPENDED
1       alsa_output.platform-soc_audio.analog-mono.2    module-alsa-card.c     s16le 1ch 44100Hz        SUSPENDED

thought: if that additional driver resulted in non-zero device ID, you might be hitting: https://github.com/MycroftAI/enclosure-picroft/issues/132

My guess is that somewhere you switched to using the new(er) (f)kms driver with the included sound driver.

Then looking at your pulse setttings you have the first analog as default, which get’s routed to the HDMI. Making sink1 default instead of sink0 would most likely fix it again.

Or check your config.txt tonor load the vc4 driver.

Thanks, I fixed the issue by:

  1. Removing the following lines from /etc/mycroft/mycroft.conf
    “play_wav_cmdline”: “aplay -Dhw:0,0 %1”,
    “play_mp3_cmdline”: “mpg123 -a hw:0,0 %1”,
  2. Setting the audio output 20 #2 via pactl set-default-sink alsa_output.platform-soc_audio.analog-mono.2
  3. Rebooting

I am not sure which one of those it was that fixed it since I ran them at the same time.