0.9.7 version broke mycroft

Well, this is my umpteenth time I reimaged Mark1. Sometime because I messed up the configuration files, sometimes because mycroft stopped working and now, just reimaged 0.9.1 version, just apt updated, apt upgraded and mycroft doesn’t understand any skill… just updated to 0.9.7.
Version 0.9.6 seemed to work, but now is completely broken. Perhaps I’ve updated just in middle of a repository maintenance, anyone has the same problem?

Thanks @malevolent for letting us know.
Do you by chance have a custom Wake Word? I’ve seen one other occurrence in 0.9.7 of it breaking a custom Wake Word.

Do you have some logs you can share - are you comfortable SSH’ing into the unit?

Best, K.

Hi there,

Yes ssh is my natural connection method at work :wink:
I’ve just imaged 0.9.1 version, inserted on mycroft, configured on home.mycroft.ai and tested (what time is it?), apt update && apt upgrade. That’s all. Stopped working.
I think the relevant logs are on mycroft-speech-client, let me know if there are others.

20:05:59.071 - mycroft.client.speech.main:handle_record_begin:35 - INFO - Begin Recording…
20:06:04.996 - mycroft.client.speech.main:handle_record_end:40 - INFO - End Recording…
20:06:05.024 - mycroft.client.speech.main:handle_wakeword:50 - INFO - Wakeword Detected: hey mycroft
20:06:05.126 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai
20:06:05.944 - mycroft.client.speech.mic:listen:499 - DEBUG - Waiting for wake word…
20:06:06.689 - requests.packages.urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 “POST /v1/stt?lang=en-US&limit=1 HTTP/1.1” 200
20:06:08.283 - mycroft.client.speech.listener:transcribe:144 - DEBUG - STT: what time is it
20:06:08.286 - mycroft.client.speech.main:handle_utterance:55 - INFO - Utterance: [u’what time is it’]
20:06:08.324 - mycroft.client.speech.main:handle_complete_intent_failure:67 - INFO - Failed to find intent.
20:07:46.719 - mycroft.configuration.config:load_local:110 - DEBUG - Configuration /usr/local/lib/python2.7/site-packages/mycroft_core-0.9.7
-py2.7.egg/mycroft/configuration/mycroft.conf loaded
20:07:46.728 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai
20:07:47.686 - requests.packages.urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 “GET /v1/device/684119d6-7ef9-48b7-818e-b79c151
63065/setting HTTP/1.1” 200 2948
20:07:47.700 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai
20:07:49.017 - requests.packages.urllib3.connectionpool - DEBUG - https://api.my
croft.ai:443 “GET /v1/device/684119d6-7ef9-48b7-818e-b79c15163065/location HTTP/1.1” 200 877
20:07:49.097 - mycroft.configuration.config:load_local:110 - DEBUG - Configuration /etc/mycroft/mycroft.conf loaded
20:07:49.100 - mycroft.configuration.config:load_local:110 - DEBUG - Configuration /home/mycroft/.mycroft/mycroft.conf loaded
20:07:49.328 - mycroft.client.speech.listener:run:307 - DEBUG - Config has changed, reloading…
20:07:49.396 - mycroft.client.speech.listener:create_wake_word_recognizer:217 - INFO - creating wake word engine
20:07:49.399 - mycroft.client.speech.hotword_factory:create_hotword:246 - INFO - creating hey mycroft
20:07:49.537 - mycroft.client.speech.listener:create_wakeup_recognizer:235 - INFO - creating stand up word engine
20:07:49.539 - mycroft.client.speech.hotword_factory:create_hotword:246 - INFO - creating wake up
20:07:49.679 - requests.packages.urllib3.connectionpool - DEBUG - Starting new HTTPS connection (1): api.mycroft.ai
20:07:50.759 - requests.packages.urllib3.connectionpool - DEBUG - https://api.mycroft.ai:443 “GET /v1/device/684119d6-7ef9-48b7-818e-b79c15163065 HTTP/1.1” 200 407


From the log it looks as if the wake word is detected (you hear the listening sound) and the utterance (‘what time is it’) is fetched from STT. But then no skill is found to handle the intent resulting in the “I’m sorry I didn’t catch that” message.

Is this a correct analysis?

If it is correct the mycroft-skills.log would be interesting to look at. To see why the skills aren’t loading.

Well, that’s kinda weird… I reimaged another SD to work in parallel with spanish translation and stick with that SD in version 0.9.1 (with other problems that aren’t related) but inserting this SD again (with 0.9.7 version) now mycroft understands everything I say… :sweat: So I cannot reproduce at the moment or perhaps it was a one-time problem…

Sorry for the mess…

No problem at all, @malevolent! Great to hear it’s working for you!

I recent did an update and I receive an error with debconf_1.5.56. Has anyone experience problems with this package. I tried to download a new version and still have the same error. I can post the actual error later, but right now it about segment fault

Hi @olewis02081,
We haven’t seen that error before, but I’d really like to help try and get to the bottom of it with you. First, are you able to confirm some details for me?

  • You’re running Mycroft Mark 1
  • Are you able to let us know which version you’e running or the last known version that was good on the Mark 1?
  • That you’re comfortable SSH’ing into the uni

Also, are you able to help by providing some logs for us:

or is it segfaulting before being able to boot?

Kind regards,

Hi Kathy and Merry Christmas.

Here is the actual error:

Preparing to unpack …/debconf_1.5.56+deb8u1_all.deb …
Segmentation fault
dpkg: warning: subprocess old pre-removal script returned error exit status 139
dpkg: trying script from the new package instead …
Segmentation fault
dpkg: error processing archive /var/cache/apt/archives/debconf_1.5.56+deb8u1_all.deb (–unpack):
subprocess new pre-removal script returned error exit status 139
Segmentation fault
dpkg: error while cleaning up:
subprocess installed post-installation script returned error exit status 139
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I get this error either on sudo apt-get upgrade or sudo apt-get install mycroft-core

I don’t know if mycroft uses this package, but I believe is part of raspberry (not sure). In either case, when I reboot mycroft Mark1 the display stays in a constant >>> Updaing <<< message.

I tried to downloading a new package using dpkg but after the download it sill is showing the same error. I was looking to how to download it manually from another site.

Finally - I ssh to the Mark1 and I use putty to connect.

Any suggestions would be great.

I the version I update is 0.9.12

@olewis02081 thanks for providing this information, it’s very helpful. I’m going to ping my colleague @forslund here, who has more knowledge around packaging and the packages that are used on Raspberry Pi 3.

Kind regards,

This rings a tiny bell, I think I may have experienced something similar back in July,
May I ask which version you had before doing the update?

If it is the same issue it was a bit tricky to get apt back in a clean state.

I suggest you try to delete the cached file

should be something along the lines of

sudo rm /var/cache/apt/archives/debconf_1.5.56+deb8u1_all.deb

Otherwise you may need to try some more unsafe methods like doing a force all installation:

sudo dpkg -i --force-all