Picroft config permission denied

Thanks for your continued help here, Mike.

ls -ld /etc returns
drwxr-xr-x 86 root root 4096 Sep 10 13:34
The same permissions as you shared but the numbers are different (86 and 4096 vs 138 and 8192) - I don’t know if that’s important.

I tried the arecord command but it returned
arecord: main:828: audio open error: No such file or directory

For reference, during the initialisation, the mic test didn’t output any sound either.

I’ve been trying to follow the guidance set out In another thread but keep running into the permissions problem - I’m using a 4B (4Gb) and seem to have everything running correctly except the sound. I haven’t tinkered with anything else or installed any skills other than the ones that came as part of the regular install process.

mycroft-cli-client shows that it’s hearing me and is responding but the only time is has any audible output is when asked to sing and that comes through on the HDMI audio channel.

“mycroft-config edit system” brings up a file that shows the outputs as:

"play_wav_cmdline": "aplay -Dhw:0,0 %1",
"play_mp3_cmdline": "mpg123 -a hw:0,0 %1"

This seems to be the HDMI output but nothing except the singing comes through on that.

I tried running Sonic Pi under Raspbian on the same machine and the sound comes through fine - so I know it’s not a hardware issue.

Resigning myself to the possibility that I may have to run through the whole install again just to choose a different audio output during setup. That’s a project for NEXT weekend.