Picroft audio problem (again, sorry)

I have RP3 B+ with raspiaudio voice hat. I don’t think mycroft’s hearing is very good. He speaks well, but when I tell him to record the play-back sound quality is very poor. Als when I say Hey Mycroft he doesn’t always hear.

I have tried tweeking the levels in alsamixer, but they are never stored on reboot. I have also tried alsctl store, but that does not work either.

In alsamixer I have 2 soundcards - ‘default’ and ‘Sound_rpi_googlevoicehat_soundcard’. Each one has two level indicators, capture and master. I could do with an explanation which card and what is master and capture

Can anyone offer some advice please

My guess is that the default is the builtin audio on the pi, and the Sound_rpi_googlevoicehat_soundcard is the voicehat.

The problem about alsactl isnt restored after boot is a problem seen often. Many do fix that by adding

amixer set  Master 75% 

to the auto_run.sh
This sets the volume, and I think for setting the mic level would be

amixer set Capture 75%

Thanks for reply
This hasn’t improved the recording quality. But the settings in alsamixer seem to have changed for the better.

However now Picroft only responds/speaks when it is connected to a monitor or when I ssh into it. I know it sounds unlikely but I swear it is true. It just does not work unless it is connected to something else.
Any ideas?

If you are connected to it over ssh and disconnect does it stay connected? Set a static ip?

Hey Mycroft works again!
But no. It didn’t seem to stay connected after I closed the ssh connection.
You are all being very patient with a stupid noob.

Hi @aaron57 they’re definitely not stupid questions!

Audio is one of the most common issues we face, and there’s plenty that can go wrong even for experienced Linux wizards. We’d much rather you ask the question on here, have a solution shared, and then have this available via search for future users who might be facing similar problems.

Glad it’s working again :slight_smile:

Hey Mycroft
I have to admit I am still having problems with audio. He speaks well, but when I tell him to record the play-back sound quality is very poor. Also, when I say Hey Mycroft he doesn’t always hear, I have to go up close and speak quite loudly.

If I do ‘arecord -d10 /home/test-mic.wav’ and ‘aplay /home/test-mic.wav’ from the command line the sound quality is way better, which leads me to think that pycroft is’nt dealing with output from the mic very well.
Thanks for reading.