Mycroft Skills Manager on Mark 2?

I just received my Mark2. Following the doc for installing new skills, I tried to install Play Spotify. That didn’t work via voice, so I figure I’ll try the command line.

I SSH over, and:

(.venv) mycroft@localhost:~$ mycroft-msm list
-bash: mycroft-msm: command not found

Is there a step I’m missing? I don’t see any instruction anywhere that I should be installing the skills manager.

1 Like

Depending on where mycroft-msm is, you probably want to add that directory to your PATH environment variable.

I’m not on a Mark II, but mine is here, so I add that directory to the end of my PATH that I set in ~/.bash_profile:

$ locate mycroft-msm
$ echo $PATH

Hope this helps.

-Mike Mac

See: Mycroft Mark II missing files

In short…documentation and skills are missing for Mycroft II. Not your fault.

Holy yikes. I guess adds up with the rest of the product release. Too much work to do and not enough time, but this sure is a very strong negative. User finally gets their Mark 2 and… proceeds to rage quit after the docs feel completely misleading and there’s no obvious way to self discover without already knowing the issue.

I strongly empathize with everybody in that thread, and it sucks to have the same experience 2 months later.


Same here … received my Mark 2 … first thing I tried was installing new skills …

I don’t understand why this wasn’t flagged up - I’m happy to get on the command line, set up ssh and try and figure things out - that’s why I bought the Mark 2. Who is buying the Mark 2 if not people like me?


Yes, I am deeply disappointed and have to admit my astonishment in these choices and the galling lack of communication by the company. That said, I’m thinking that we in the wider Mycroft community can participate in the documentation and get it to the point we believe it should be at. What is the point of FLOSS if I / we just sit back to judge but don’t contribute? To my mind this joint agency is what makes FLOSS (Free / Libre Open Source Software / Hardware / Technology) the freedom - creating wonder that it is.


Yeah, feels like a huge grift. I gave money. I waited patiently. I now have a $400 device that can’t do anything better than my watch. Some may argue that at least I have the hardware but I have raspberry pis, screens, dacs, mic arrays and all of that stuff littering my office.

What I wanted was a privacy based rival to My Echos so I could start phasing them out. This is not it. I can now understand why there was a shake up in leadership. I would have left too if this was the decision being mulled over.

I have played every roll in an IT shop. Sys Admin, Business Analyst, Applications Director, CIO, Scrum Master, etc. I would absolutely never allow my teams to roll out a product with one of the major features that was announced(skill marketplace) removed completely - with bad documentation and poor communication to boot!

My friends and family have made the Mark II the joke of the Christmas season after seeing what I got vs. what I told them was finally arriving.


Except we were sold something different than what we purchased and I, for one, don’t want to put the work in that should have been done by the Mycroft team. I would prefer to get my money back and to just go back to being spied on until someone that actually knows what they are doing rolls out a privacy based home assistant.