Mark I does not properly work after waking up from naptime

When I wake up my Mark I (“hey mycroft, wake up”) I reproducibly have the following issues

  1. Wifi does not work (Mycroft says he is not connected to the internet)

  2. (when connected via LAN) Mycroft does not speak - no output from the Mark I’s speaker

After Reboot Wifi usually does work again and Mycroft sets Time&Date (display shows “< < < sync < < <”). It reacts to “hey mycroft” but a response is still not audible, only after turning Mark I’s (volume) knob the audio output does work again. The audio volume then is at 100% level although it was set to a lower level before.

It seems to me that some hardware components are not correctly initialized when waking up the Mark I from sleep mode.

Hi there @Dominik, thanks both for reporting these issues, and for indicating that they are reproducible. Issue #2 is a known error, and is documented as an Issue on GitHub.

Issue #1 with WiFi not working - I wasn’t able to reproduce this. My guess is that it will be something specific to the Mark 1 with your particular router / SSID / WLAN environment. Would you be OK if I asked some further information to help try and diagnose this issue? I don’t want to presume.

Kind regards,

Hello @KathyReid, which information do you need?

Great, thanks for offering to help.

  • Can you please ssh to the Mark 1
  • Then run the command sudo iwlist wlan0 frequency
  • This tells me which WLAN frequencies it can see
  • Then run the command sudo iw reg get
  • This tells me what ‘country’ your Device is set to

Next, can you let me know if your router is using DHCP and what the lease time / TTL is on the leases?

Kind regards, Kathy

Here are the results:

pi@mark_1:~ $ sudo iwlist wlan0 frequency
wlan0     13 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Current Frequency:2.437 GHz (Channel 6)

The Wifi-module of the Mark I/Raspberry Pi3 seems to support channel 12/13 while I had to turn these of in my router (you probably remember that I have reported that earlier this week)

pi@mark_1:~ $ sudo iw reg get
country DE: DFS-ETSI
	(2400 - 2483 @ 40), (N/A, 20), (N/A)
	(5150 - 5250 @ 80), (N/A, 20), (N/A), NO-OUTDOOR
	(5250 - 5350 @ 80), (N/A, 20), (0 ms), NO-OUTDOOR, DFS
	(5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS
	(5725 - 5875 @ 80), (N/A, 13), (N/A)
	(57000 - 66000 @ 2160), (N/A, 40), (N/A)

Country DE for Germany is correct.

Next, can you let me know if your router is using DHCP and what the lease time / TTL is on the leases?

My router is configured to use DHCP with a lease time of 5 days.

Today Wifi worked without problems when waking up the Mark I from sleep. I will report back when the problem reoccurs.

1 Like

Thanks again @Dominik