Initial setup Mark 1

In case it helps anyone, I struggled for a while with trying to register Mycroft Mark 1 when my phone was connected to the Mycroft network. The advice if you don’t immediately get a pop-up asking for the code (which you don’t) is to visit
BUT after many tries, I eventually managed to get it working by visiting :

Hopefully this will help someone.

Thanks @roy for reporting this, really appreciate it.

Are you comfortable sshing in to your Device? If so, I can guide you through having a look at the wireless setup logs to see what the issue might be.

Best, Kathy

yes I don’t mind ssh’ing
Let me know what to look for and I’ll do that (sometime soon) :grinning:

should mention I was using this :

I’d let the Mark 1 lie on the shelf for a while and when I eventually tried to set it up I couldn’t get past yellow eyes. It listened alright, but the only response it would make was to say “Please wait a moment as I finish booting up”

sudo apt-get update and upgrade etc didn’t fix it so I resorted to downloading the image and burning it to SD.

After that is when I had the issue with and solved it by using


First, ssh into your Mark.
Next, cd /var/log
ls -las | grep mycroft will show you all the mycroft-* logs

cat mycroft-wifi-setup-client.log will show the log from setting up wireless.

that log file appears to be empty but is sized 1 byte, so maybe it has a space in it.