Finally Got It Working

System: Kubuntu 16.04
KDE Plasma: 5.8.9
KDE Frameworks: 5.36
QT: 5.6.1
Kernel: 4.4.0-141-generic
OS Type: 64-bit
CPU: Intel Core i5 750 (4 cores) @ 2.67GHz
Memory: 7.8Gb RAM
Sound Card:
–external USB Sound Blaster 24 Live! with 5.1 speakers
–internal Realtek card used for microphone input
–Phonon GStreamer backend

python v. 2.7.12
python3 v. 3.5.2

Using ALSA with PulseAudio

Video: AMD Radeon HD 5670

System dates to 2011.

Problems Installing:

I had tried to install Mycroft a few months ago but during the install process it wanted to remove about half of my programs. This time I ran the installer and automatically removed about 30 programs and 300+ libraries from my computer. I knew the risk, however, and I’m fascinated by AI.

To make it short: it was portaudio19-dev that caused all my troubles. It installs libjack0, which is incompatible with libjack-jack2-0. The removal of the latter caused automatically wine to be removed, and with it all the wine software in my machine. It also caused the removal of simplescreenrecorder, blender, and many components of openshot and kdenlive. And mpg123, which is used by basically all my sound-manipulation programs.

I bit the bullet, installed mycroft (had to install the full repository, going only one directory in depth didn’t work with the main branch at all), then reinstalled most of what I lost (some of my wine games are gone for good, I had got rid of the disks already), and removed that pesky portaudio19-dev and all its dependencies to go back to libjack-jack-2-0.

The only problem with that is that it affects the availability of dbus for the pyaudio package, and that means I cannot install some of the “skills,” but the two I can’t install (krunner-search and plasma-activities) require the plasmoid. You cannot install the plasmoid in Kubuntu 16.04, since it requires the package qml-module-qtquick-controls2 that is not available for Xenial installs, only for Bionic onwards.

Making the machine recognize a custom word was a pain. I gave up trying with the precise listener and switched to pocketsphinx, I just had to change my word to one found in the dictionary and that was close enough. To adjust time, weather reports, and reported location, I had to create the mycroft.conf file (put it in my own settings directory, ~/.mycroft, but if I want to make it available to all those who use the machine, I’d have to create /etc/mycroft/ and put it there).

The skills are in /opt/mycroft/, and the mycroft_web_cache.json is in /var/tmp/. While I get why it was put there, it’s still a terrible place IMO. At any rate, it didn’t give me any trouble with my iptables, and I’m the “security conscious” sort who keep the machine invisible from the outside with a bunch of tools making sure no one starts sniffing where they shouldn’t. So that works, although not 100%.

Because the “how far is $CITY$?” question is still assuming we’re in New York City. I’m not there, most certainly. I fear this is a bit of bad coding somewhere, because unlike others I’ve managed the lat/lon coordinates to be correct. I remember reading a report of the coordinates being wrong, and still the city distance calculator giving the answers not for somewhere in Germany or somewhere off the Somalian coast, but for somewhere in Queens, NYC.

It took no little effort, also, to convince Mycroft, initially, that I was not in Lawrence, Kansas. I had to be very precise with the TZ format, specifying city, state (and I’m in Canada, where we got provinces, but Mycroft still requires states), timezone, and the correct time offsets (tip: dst0ffset is 3600000 for when you move forward one hour in the summer, which is mostly the case; offset is the number of hours in front or behind Greenwich, so if you’re on the Pacific Coast, it’s -8 hours x 3,600 seconds per hour x 1,000 milliseconds per second = -28800000).

The weather finally works like a charm. It took a good chunk of my weekend to get most everything to work nicely (except for the city-distance part, and the skills that require the plasmoid, which needs Kubuntu 18.04, and that luckily so far coincide with the ones that require I remove my libjack-jack-2-0, which cannot happen, it’d break the programs I use the most).

This computer is used mainly for video/sound editing, and frankly I’m not a gamer, so the loss of the games is sad, but no big deal. I just hope when Mycroft updates itself (I’ve set that to automatic), it doesn’t try to remove any of my programs again.

So, congrats you all.


PS: It’d be nice to have a manual somewhere to explain the format used in the config files. I get it’s mostly standard IANA TZ database stuff, and the formats are standard python, but for us non-coders it’s a pain to figure that out.

1 Like

Thanks for the great write up!

If you could add a note to the feedback form on our mycroft.conf documentation, this means it will get picked up when we review our docs.